收藏 分销(赏)

九章路径与形状工具.ppt

上传人:天**** 文档编号:14660467 上传时间:2026-10-26 格式:PPT 页数:41 大小:1.45MB 下载积分:10 金币
下载 相关
九章路径与形状工具.ppt_第1页
第1页 / 共41页
九章路径与形状工具.ppt_第2页
第2页 / 共41页


点击查看更多>>
资源描述
*,单击此处编辑母版标题样式,单击此处编辑母版文本样式,第二级,第三级,第四级,第五级,第九章 路径与形状工具,第九章 路径与形状工具,第一节 路径与形状工具,第二节 路径调板,第三节 形状操作与编辑,第一节 路径与形状工具,一、路径与形状工具,1定义,路径:(,PATH),是,Photoshop,中的重要工具,主要用于进行光滑图像选择区域及辅助抠图,绘制光滑线条,定义画笔等工具的绘制轨迹,输出输入路径及和选择区域之间转换。,路径可以转换为选区,或者使用颜色填充和描边的轮廓。形状的轮廓是路径。通过编辑路径的锚点,可以很方便地改变路径的形状,Photoshop,提供了三组用于生成、编辑、设置路径的工具组。,【路径选择工具】和【直接选择工具】,钢笔工具组总计五个,钢笔工具是最常用的路径节点定义工具,一般手工定义节点均使用此工具:,形状工具组,总计六个:,使用形状或钢笔工具时,有三种不同的模式。在选定形状或钢笔工具时,可通过选择选项栏中的图标来选取一种模式。,形状图层:在单独的图层中创建形状。可以使用形状工具或钢笔工具来创建形状图层。因为可以方便地移动、对齐、分布形状图层以及调整其大小,所以形状图层非常适于为,Web,页创建图形。,路径:在当前图层中绘制一个工作路径,可随后使用它来创建选区、创建矢量蒙版,或者使用颜色填充和描边以创建栅格图形(与使用绘画工具非常类似)。,填充像素:直接在图层中绘制,与绘画工具的功能非常类似。在此模式下不能使用钢笔工具。,二、钢笔工具,1、钢笔工具属于矢量绘图工具,其优点是可以勾画平滑的曲线,在缩放或者变形之后仍能保持平滑效果。2、钢笔工具画出来的矢量图形称为路径,路径是矢量的路径允许是不封闭的开放状,如果把起点与终点重合绘制就可以得到封闭的路径。,3,、钢笔工具可以创建直线和平滑流畅的曲线。可以组合使用钢笔工具和形状工具以创建复杂的形状。(一)用钢笔工具绘图:,1、选择钢笔工具 2、设置工具特定选项:3、将钢笔指针定位在绘图起点处并点按,以定义第一个锚点。,4、点按或拖移,为其他的路径段设置锚点。,5、完成路径,。,(二)用钢笔工具绘制直线段:,1、将钢笔指针定位在直线段的起点并点按,以定义第一个锚点。,2、在直线第一段的终点再次点按,或按住,Shift,键点按将该段的角度限制为 45 度角的倍数。,3、继续点按,为其他的段设置锚点。,(三)用钢笔工具绘制曲线:,通过沿曲线伸展的方向拖移钢笔工具可以创建曲线。1、将指针定位在曲线的起点,并按住鼠标按钮。出现第一个锚点。2、向绘制曲线段的方向拖移指针。3、将指针定位在曲线段的终点,并向相反方向拖移可完成曲线段。4、执行下列操作之一:,(1)要绘制平滑曲线的下一段,请将指针定位在下一段的终点,并向曲线外拖移。,(2)沿着偏离曲线的方向拖移可创建下一段。,(3)要急剧改变曲线的方向,释放鼠标按钮,然后按住,Alt,键沿曲线方向拖移方向点。松开,Alt,键以及鼠标按钮,将指针重新定位在曲线段的终点,并向相反方向拖移以完成曲线段。,(4)要间断锚点的方向线,按住,Alt,键拖移方向线。,在绘制曲线时,记住以下原则:,1、在创建曲线时,总是向曲线的隆起方向拖移第一个方向点,并向相反的方向拖移第二个方向点。同时向一个方向拖移两个方向点将创建【,S】,形曲线。,2、在绘制一系列平滑曲线时,一次绘制一条曲线,并将锚点置于每条曲线的起点和终点而不是曲线的顶点。,3、要减小文件大小并减少可能出现的打印错误,请尽可能使用较少的锚点,并尽可能将它们分开放置。,(四)用自由钢笔工具绘图:,自由钢笔工具可用于随意绘图,就像用铅笔在纸上绘图一样。在绘图时,将自动添加锚点,无需确定锚点的位置,完成路径后可进一步对其进行调整。,1、选择自由钢笔工具。2、要控制最终路径对鼠标或光笔移动的灵敏度,请点按选项栏中形状按钮旁边的反向箭头,然后为【曲线拟合】输入介于 0.5 到 10.0 像素之间的值。此值越高,创建的路径锚点越少,路径越简单。3、在图像中拖移指针。在您拖移时,会有一条路径尾随指针。释放鼠标,工作路径即创建完毕。4、要继续创建现有手绘路径,请将钢笔指针定位在路径的一个端点,然后拖移。5、要完成路径,请释放鼠标。要创建闭合路径,请将直线拖移到路径的初始点(当它对齐时会在指针旁出现一个圆圈)。,(五)用磁性钢笔绘图 磁性钢笔是自由钢笔工具的选项,它可以绘制与图像中定义区域的边缘对齐的路径。可以定义对齐方式的范围和灵敏度,以及所绘路径的复杂程度。,1、要将自由钢笔工具转换成磁性钢笔工具,在选项栏中选择【磁性】,或点按选项栏中形状按钮旁边的反向箭头。(1)为【宽度】输入介于1到256之间的像素值。磁性钢笔只检测距指针指定距离内的边缘。(2)为【对比】输入介于1到100之间的百分比值,指定将该区域看作边缘所需的像素对比度。此值越高,图像的对比度越低。(3)为【频率】输入介于0到100之间的值,指定钢笔设置锚点的密度。此值越高,路径锚点的密度越大。(4)如果使用的是光笔绘图板,选择或取消选择【钢笔压力】。当选择该选项时,钢笔压力的增加将导致宽度减小。,2、在图像中点按,设置第一个紧固点。,3、要手绘路径段,移动指针或沿要描的边拖移。,磁性钢笔定期向边框添加紧固点,以固定前面的各段。,4、如果边框没有与所需的边缘对齐,则点按一次以手动添加一个紧固点,并使边框保持不动。继续沿边缘操作,根据需要添加紧固点。如果出现错误,按,Delete,键删除上一个紧固点。,5、动态修改磁性钢笔的属性,执行下列操作之一:,(1)按住,Alt,键并拖移,可绘制手绘路径。(2)按住,Alt,键并点按,可绘制直线段。(3)按左方括号键()可将磁性钢笔的宽度减小1个像素;按右方括号键()可将钢笔宽度增加1个像素。,6、完成路径:,(1)按,Enter,键结束开放路径。(2)点按两次,闭合包含磁性段的路径。(3)按住,Alt,键并点按两次,闭合包含直线段的路径。,【作业】,如何把图,A,的直线路径变为图,B,的曲线效果。,图,A,图,B,第二节 路径调板,一、路径调板,【路径】调板列出了每条存储的路径、当前工作路径和当前矢量蒙版的名称和缩览图像。,(1)要显示【路径】调板,选取【窗口】-【路径】。,(2)要选择路径,点按【路径】调板中相应的路径名。一次只能选择一条路径。(3)要取消选择路径,点按【路径】调板中的空白区域或按,Esc,键。,(4)要更改路径缩览图的大小,从【路径】调板菜单中选取【调板选项】,然后选择大小或选择【无】关闭缩览图显示。,(5)要更改路径的堆叠顺序,在【路径】调板中选择该路径,然后上下拖移该路径。当所需位置上出现黑色的实线时,释放鼠标按钮。,【路径】调板中矢量蒙版或工作路径的顺序不能更改。,(一)管理路径:当使用钢笔工具或形状工具创建工作路径时,新的路径以工作路径的形式出现在【路径】调板中。工作路径是临时的,必须存储它以免丢失其内容。当使用钢笔工具或形状工具创建新的形状图层时,新的路径会以矢量蒙版的形式出现在【路径】调板中。矢量蒙版与其父图层链接;必须在图层调板中选择父图层,【路径】调板中才会列出剪贴路径。可以从图层中删除剪贴路径和将剪贴路径转换成栅格化蒙版。,(二)在路径调板中创建新路径:,1、要创建路径而不命名它,请点按【路径】调板底部的【创建新路径】按钮。2、要创建并命名路径,请确保没有选择工作路径。从【路径】调板菜单中选取【新建路径】,或按住,Alt,键并点按调板底部的【创建新路径】按钮。在【新路径】对话框中输入路径的名称,并点按【确定】。,(三)创建新的工作路径:,1、选择形状工具或钢笔工具,然后点按选项栏中的【路径】按钮。2、设置工具特定选项并绘制路径。3、如果需要,可绘制其他路径组件。通过点按选项栏中的工具按钮,可以很容易地在绘图工具之间切换。选择路径区域选项以确定重迭路径组件如何交叉。(1)添加到路径区域将新区域添加到重叠路径区域。(2)从路径区域减去将新区域从重叠路径区域移去。(3)交叉路径区域将路径限制为新区域和现有区域的交叉区域。(4)重叠路径区域除外从合并路径中排除重叠区域。,在使用形状工具绘制时,按住,Shift,键可临时选择【添加到路径区域】选项;按住,Alt,键可临时选择【从路径区域减去】选项。,(四)存储工作路径:,1、要存储路径但不重命名它,请将工作路径名称拖移到【路径】调板底部的【新路径】按钮。,2、要存储并重命名路径,请从【路径】调板菜单中选取【存储路径】,然后在【存储路径】对话框中输入新的路径名,并点按【确定】。,(五)重命名存储的路径:,点按两次【路径】调板中的路径名,键入新的名称,然后按,Enter,键。,(,六)删除路径:,1、在【路径】调板中点按路径名。,2、执行下列操作之一:,(1),将路径拖移到【路径】调板底部的【删除】图标中。,(,2),从【路径】调板菜单中选取【删除路径】。,(,3),点按【路径】调板底部的【删除】图标,然后点按【是】。,(,4),要删除路径而无需确认,按住,Alt,键并点按【路径】调板底部的【删除】图标。,二、编辑路径,(一)选择路径:选择路径组件或路径段将显示选中部分的所有锚点,包括全部的方向线和方向点。,1、执行下列操作之一:(1)要选择路径组件(包括形状图层中的形状),选择路径选择工具,并点按路径组件中的任何位置。,(2)要选择路径段,选择直接选择工具,并点按段上的某个锚点,或在段的一部分上拖移选框。(3)拖移选框以选择段。,2、要选择其他的路径组件或段,选择路径选择工具或直接选择工具,然后按住,Shift,键并选择其他的路径或段。,(二)移动直线路径段:1、选择直接选择工具,然后选择要调整的段。要调整段的角度或长度,请选择锚点。2、将所选段拖移到它的新位置。,(三)移动曲线段:1、选择直接选择工具,然后选择要移动的点或段。确保选择定位段的两个锚点。2、将所选锚点或段拖移到新位置。拖移时按住,Shift,键可限制按45 度角的倍数移动。,(四)删除段:1、选择直接选择工具,然后选择要删除的段。2、按,Backspace,键删除所选段。再次按,Backspace,键或,Delete,键可删除其余的路径组件。,(五)对齐并分布路径组件,既可以对齐也可以分布在单个路径中描述的路径组件。,(六)对齐组件:,1使用路径选择工具,选择要对齐的组件,然后从选项栏中选择对齐选项:,顶对齐 垂直中齐 底对齐 左对齐 水平中齐 右对齐,2对齐或分布路径组件:至少选择三个要分布的组件,然后从选项栏中选择分布选项:,按顶分布 垂直居中分布 按底分布 按左分布,水平居中分布 按右分布。,(七)添加锚点:,1、选择添加锚点工具,并将指针放在要添加锚点的路径上(指针旁会出现加号)。,2、执行下列操作之一:(1)要添加锚点但不更改线段的形状,请点按路径。(2)要添加锚点并更改线段的形状,请拖移以定义锚点的方向线。,如果已在钢笔工具或自由钢笔工具的选项栏中选择了【自动添加/删除】,则在点按直线段时,将会添加锚点,而在点按现有锚点时,则会将该锚点删除。,(八)删除锚点:1、选择删除锚点工具,并将指针放在要删除的锚点上(指针旁会出现减号)。2、删除锚点。1、点按锚点将其删除,路径的形状重新调整以适合其余的锚点。2、拖移锚点将其删除,线段的形状随之改变。如果已在钢笔工具或自由钢笔工具的选项栏中选择了【自动添加/删除】,则在点按直线段时,将会添加锚点,而在点按现有锚点时,则会将该锚点删除。,(九)使用颜色填充和描边路径:,使用钢笔工具创建的路径只有在经过描边或填充处理后,才会成为图素。,【填充路径】命令可用于使用指定的颜色、图像状态、图案或填充图层来填充包含像素的路径。,【描边路径】命令可用于绘制路径的边框。这和【描边】图层的效果完全不同,它并不模仿任何绘画工具的效果。,当填充或描边路径时,颜色值会出现在现用图层中。开始之前,所需图层一定要处于现用状态。当图层蒙版或文本图层处于现用状态时,无法填充或描边路径。,(十)使用当前填充路径设置填充路径,在【路径】调板中选择路径。,点按【路径】调板底部的【填充路径】按钮。,(十一)填充路径并指定选项,1、在【路径】调板中选择路径。,2、填充路径:,3、对于【使用】,选取填充内容,4、指定填充的不透明度。,5、选取填充的混合模式。,6、选取【保留透明区域】仅限于填充包含像素的图层区域。,7、选择【渲染】选项:,羽化半径:定义羽化边缘在选区边框内外的伸展距离。,消除锯齿:通过部分填充选区的边缘像素,在选区的像 素和周围像素之间创建精细的过渡。,8、【确定】。,(十二)使用当前描边路径设置描边路径:,在【路径】调板中选择路径。,点按【路径】调板底部的【描边路径】按钮。每次点按【描边路径】按钮都会增加描边的不透明度,在某些情况下使描边看起来更粗。,(十三)描边路径并指定选项,1、在【路径】调板中选择路径。,2、选择要用于描边路径的绘画或编辑工具。设置工具选项,并从选项栏中指定画笔。在打开【描边路径】对话框之前,必须指定工具的设置。有关特定工具设置的信息,请参阅使用涂抹工具和绘画。,3、要描边路径,请执行下列操作之一:(1)按住,Alt,键并点按【路径】调板底部的【描边路径】按钮。(2)按住,Alt,键并将路径拖移到【描边路径】按钮。(3)从【路径】调板菜单中选取【描边路径】。如果所选路径是路径组件,此命令将变为【描边子路径】。,4、如果没有在第2步中选择工具,从【描边路径】对话框中选取工具。,5、点按【确定】。,【作业】,如何把图,A,的路径变为图,B,的选区效果,如何把图,B,进行填充如图,C。,图,A,图,B,图,C,第三节 形状操作与编辑,一、形状操作与编辑,(一)在形状图层上创建形状:,1、选择一个形状工具或钢笔工具。,2、要选取形状的颜色,在选项栏中点按色板,然后从拾色器中选取一种颜色。,3、在选项栏中设置工具选项。点按形状按钮旁边的反向箭头以查看每个工具的其他选项。,4、要为形状应用样式,从选项栏的【样式】弹出式菜单中选择预设样式。,5、在图像中拖移可绘制形状。(按住,Shift,键,将矩形或圆角矩形约束成方形,将椭圆约束成圆,或将线条角度限制为 45 度角的倍数。),(二)绘制自定形状:,1、从选项栏中的【自定形状】弹出式调板中选择一个形状。,2、点按调板右上角的箭头,然后选取其他类别的形状。当询问是否替换当前形状时,点按【替换】以仅显示新类别中的形状,或点按【追加】以添加到已显示的形状中。,3、在图像中拖移可绘制形状。,(三)在图层中绘制多个形状:,可在图层中绘制单独的形状,或者使用【添加】、【减去】、【交叉】或【除外】选项来修改图层中的当前形状。,(四)选择自定形状:,1、选择自定形状工具。,2、从选项栏的【形状】弹出式调板中选择一个形状。,(五)将形状或路径存储为自定形状:,1、在【路径】调板中选择路径,可以是形状图层的矢量蒙版,也可以是工作路径或存储的路径。,2、选取【编辑】-【定义自定形状】,然后在【形状名称】对话框中输入新自定形状的名称。新形状出现在【形状】弹出式调板中。,3、要将新的自定形状存储为新库的一部分,从弹出式调板菜单中选择【存储形状】。,(六)创建栅格化形状:,通过建立选区并用前景色填充来创建栅格化形状。,1、选择图层。在基于矢量的图层上无法创建栅格化形状。,2、选择形状工具,然后点按选项栏中的【填充像素】按钮。,3、在选项栏中设置下列选项:模式 控制形状如何影响图像中的现有像素。不透明度 决定形状遮蔽或显示其下面像素的程度。消除锯齿 混合边缘像素和周围像素。,4、设置其他特定于工具的选项。,5、绘制该形状。,(七)形状工具选项:,“箭头的起点和终点”向直线中添加箭头。选择直线工具,然后选择【起点】,即可在直线的起点添加一个箭头;选择【终点】即可在直线的末尾添加一个箭头。,在,Photoshop,中,也可以通过矢量选区和绘图工具直接编辑箭头。,“圆形”(,Photoshop),将椭圆约束为圆。“角半径”(,ImageReady),指定用来渲染圆角矩形或凸耳矩形的角半径。“定义的比例”(,Photoshop),基于创建自定形状时所使用的比例对自定形状进行渲染。“定义的大小”(,Photoshop),基于创建自定形状时的大小对自定形状进行渲染。“固定大小”根据您在【宽度】和【高度】文本框中输入的值,将矩形、圆角矩形、椭圆或自定形状渲染为固定形状。,“从中心”(,Photoshop),从中心开始渲染矩形、圆角矩形、椭圆或自定形状。,“缩进边依据”(,Photoshop),将多边形渲染为星形。在文本框中输入百分比,指定星形半径中被点占据的部分。如果设置为 50%,则所创建的点占据星形半径总长度的一半;如果设置大于 50%,则创建的点更尖、更稀疏;如果小于 50%,则创建更圆的点。,“比例”(,Photoshop),根据您在【宽度】和【高度】文本框中输入的值,将矩形、圆角矩形、或椭圆渲染为成比例的形状。,“半径”(,Photoshop),对于圆角矩形,指定圆角半径。对于多边形,指定多边形中心与外部点之间的距离。,“边数”(,Photoshop),指定多边形的边数。,“平滑拐角或平滑缩进”(,Photoshop),用平滑拐角或缩进渲染多边形。,“对齐像素”(,Photoshop),将矩形或圆角矩形的边缘对齐像素边界。,方形(,Photoshop),将矩形或圆角矩形约束为方形。,“不受限制”(,Photoshop),允许通过拖移设置矩形、圆角矩形、椭圆或自定形状的宽度和高度。,“粗细”以像素为单位确定直线的宽度。,二、编辑形状,形状是链接到矢量蒙版的填充图层。通过编辑形状的填充图层,可以很容易地将填充更改为其他颜色、渐变或图案。也可以编辑形状的矢量蒙版以修改形状轮廓,并对图层应用样式。,1、要更改形状颜色,点按两次【图层】调板中形状图层的缩略图,然后用拾色器选取一种不同的颜色。,2、要使用图案或渐变来填充形状,在【图层】调板中选择一个形状图层,然后选取【图层】-【更改图层内容】-【渐变】,并设置渐变选项。,3、要使用图案或渐变来填充形状,在【图层】调板中选择一个形状图层,然后选取【图层】-【更改图层内容】-【图案】,并设置图案选项。,4、要修改形状轮廓,在【图层】调板或【路径】调板中点按形状图层的矢量蒙版缩览图。然后使用形状和钢笔工具更改形状。,5、要移动形状而不更改其大小或比例,请按住空格键的同时拖移形状。,【作业】,一、实例,新建一个文件,白色背景,使用形状工具制作蝴蝶的效果。,
展开阅读全文

开通  VIP、SVIP  下载更划算
下载10份以上建议开通 VIP 会员
下载20份以上建议开通SVIP会员


开通VIP      成为共赢上传

当前位置:首页 > 包罗万象 > 大杂烩

移动网页_全站_页脚广告1

关于我们      便捷服务       自信AI       AI导航        关注我们

©2010-2026 宁波自信网络信息技术有限公司  版权所有

客服电话:0574-28810668  投诉电话:18658249818

gongan.png浙公网安备33021202000488号   

icp.png浙ICP备2021020529号-1  |  浙B2-20240490  

关注我们 :微信公众号    抖音    微博    LOFTER 

客服