资源描述
,第二级,第三级,第四级,第五级,*,第2章 电原理图编辑,第二级,第三级,第四级,第五级,*,第2章 电原理图编辑,第1章 Protel概述,1.1 Protel 99概述,1.2 Protel 99的文件结构,设计流程图,1.1 Protel99SE概述,美国ACCEL Technologies公司于,1988,年推出了在当时非常受欢迎的电子线路CAD软件包,TANGO,,它具有操作方便、易学、实用、高效的特点。,Protel,是TANGO的升级版本,也是影响最大、用户最多的CAD软件包之一。,(1)将,电原理图编辑(Schematic Edit)、印制电路板设计(PCB)、可编程逻辑器件PLD设计、自动布线(Route)、电路模拟/仿真(Sim),等功能有机地结合在一起,是真正意义上的EDA软件,智能化、自动化程度高。,(2)支持由上到下或由下到上的层次电路设计,使Protel99能够完成大型、复杂的电路设计。,(3)当电原理图中的元件来自,仿真元件库,时,可以直接对电原理图中的电路进行仿真测试。,Protel99SE的特点,:,(4)提供,ERC,(电气法则检查)和,DRC,(设计规则检查),最大限度地减少设计差错。,(5)库元件的管理、编辑功能完善,操作非常方便。通过基本的作图工具,,即可完成原理图用元件电气图形符号以及PCB用元件封装图形的编辑、制作,。,(6)全面兼容TANGO及Protel for DOS,即在Protel98中可以使用、编辑TANGO或低版本Protel建立的文件,并提供了与OrCAD格式文件转换功能。,启动Protel 99将非常容易,,双击,桌面上的,“Protel 99”快捷,启动方式或,单击,“,开始程序”里“Protel99”里的快捷方式,,均可启动Protel99。Protel99启动后的操作界面如图1-2所示。,1.2.2 Protel 99的启动,图1-2 Protel99界面,单击Protel99SE主画面“File”(文件)菜单下的“New”(新项目)命令,即可创建一个新的设计文件库,(.ddb),,如图1-3所示。,如何创建一个新的设计数据库文件?,图,1-3,设计文件库,关于加密,文件存放路径,图1-4 创建设计文件库后的界面,怎样看设计文件夹的结构?,在“设计文件列表”窗内,,单击,设计文件库(test.ddb)前的小方块(或,直接双击test.ddb,),即可看到设计文件库(.ddb)内文件夹结构,再单击各文件夹前的小方块即可显示或隐藏文件夹内文件目录结构,如图1-5所示。,图,1-5,设计文件库(,.ddb,)的结构,存放了设计队伍(存放在Members文件夹内)、文件访问权限以及会议记录等日常设计管理信息。,怎样建立一个新文挡?,单击“设计文件管理器”窗口内的“,Documents,”文件夹或工作窗口内的“Documents”标签后,再单击“,File,”(文件),菜单内即刻出现“,New,”(创建新文件)命令。执行“File”菜单下的“New”(创建新文件)命令,将弹出如图1-6所示的新文档(New Document)选择窗口。,图,1-6,新文档选择窗,原理图文件,PCB 文件,图1-7 系统创建的原理图文件名,“设计文件管理器”的使用方法与Windows 中“资源管理器”的使用方法完全相同。,1.2.3 Protel99中的文件管理,执行“File”菜单下的“,Open,”命令(或直接单击工具栏内的“,打开”按钮,,即可打开一个已存在的设计文件库,如图1-9所示。,图,1-8,打开设计文件库选择窗,图,1-9,设计文件库,Z80 Microprocessor.ddb,结构,图,1-10,设计文件库(,.ddb,)内文件夹结构,第2章 电原理图编辑,2.1 电原理图概念及绘制规则,2.2 Protel99原理图编辑器(SCH)的启动及界面认识,2.3 绘制原理图,2.4 利用画图工具添加说明性图形和文字,2.5 原理图的编辑技巧,2.6 元件自动编号,2.7 原理图的电气检查,2.8 存盘及文件管理,2.9 原理图的打印,2.10 报表建立与输出,2.11 电路编辑举例,2.12 元件电气图形符号编辑与创建,2.13 创建自己的图纸文件,2.14 原理图操作技巧,2.1 电原理图概念及绘制规则,所谓电原理图编辑就是使用电子元器件的,电气图形符号,以及绘制电原理图所需的,导线,、,总线,等绘图工具来描述电路系统中各元器件之间的连接关系。,1.电原理图概念,所使用的是一种符号化、图形化的语言!,下面以放大电路为例说明 电原理图的编辑方法:,(4),在工作区内放置元器件,:先放置核心元件的电气图形符号,再放置电路中剩余元件的电气图形符号。,2.电原理图编辑器(SCH)的操作步骤,(1),设置SCH编辑器的工作参数,(不是必须,可以采用系统,缺省,的参数工作,尤其是初学者,可以先不修改系统工作参数)。,(2),选择图纸幅面、标题栏式样、图纸放置方向等,(对于初学者来说也可以先采用,缺省,设置)。,(3),放大绘图区,,直到绘图区呈现大小适中的栅格线为止。,(12),打印,。,(5),调整元件位置,。,(6),修改、调整元件的标号、型号及其字体大小、位置等,。,(7),连线、放置电气节点、网络标号以及I/O端口,。,(8),放置电源及地线符号,。,(9),运行电气设计规则检查(ERC),,找出原理图中可能存在的缺陷。,(10),加注释信息,。,(11)生成网络表文件(或,直接执行PCB更新命令,,自动产生一个同名的PCB文件)。,2.2 Protel99原理图编辑器(SCH)的启动及界面认识,首先在Documents文档下,自动创建,一个以,“Sheet n”,为文件名的,原理图文件,(但文件名并未确定,处于重命名状态,用户可以直接修改文件名,然后按回车键或单击鼠标左键确认),如图2-2所示。,2.2.1 原理图编辑器窗口组成,图,2-2,系统创建的原理图文件名,在图2-2中,直接,双击,“设计文件管理器”窗口内“Documents”文件夹下相应的,原理图文件名,即可进入电原理图编辑状态,如图2-3所示。,如何进入电原理图编辑?,图,2-3,原理图编辑窗口,它由,菜单栏、工具栏、原理图编辑窗,等部分组成。在原理图编辑窗口上还有各种设计文件标签,以方便编辑器、文件之间的切换。,菜单栏内包含了“File”(文件操作)、“Edit”(编辑)、“View”(浏览)、“Place”(放置)、“Design”(设计)、“Simulate”(模拟仿真)、“Tools”(工具)、“PLD”(可编程器件)等菜单项,这些菜单命令的用途将在后续操作中逐一介绍。,Protel99原理图编辑窗口的组成?,绘制原理图前的准备工作一,放大的原理图编辑区,PageUp,PageDown,图,2-5 Document Options(,文档选择,),设置窗口,绘制原理图前的准备工作二,设计选项(,文档选择,),设置窗口,图,2-5 Document Options(,中文,),设置窗口,设置栅格的大小,设置元件移动的最小单位距离,英制尺寸:10是指的10mil,1英寸1000mil,关于公英制,Protel99中一般默认的是英制单位!,换算关系:,1英寸25.4mm,1),选择图纸大小,缺省时使用英制图纸尺寸中的“,B,”号图,公制尺寸:,A0、A1、A2、A3、A4(最小),英制尺寸:A、B、C、D、E(最小),图2-6 图纸各部分名称,图,2-8,设置,SCH,编辑器工作环境,绘制原理图前的准备工作三,Small cursor90,Large cursor90,Small cursor45,Dot Grid,Line Grid,工具优选项(,设置SCH编辑器工作环境,),图,2-8,设置,SCH,编辑器工作环境(中文),自动放置电气节点选项,任意角度连线,,一般不使用,2.3,绘制原理图,设置了,Protel99,原理图编辑器的工作环境、图纸尺寸等参数后,就可以在当前图纸的工作区内绘制、编辑原理图。,下面以绘制、编辑如图,2-10,所示的电路为例,介绍电原理编辑的基本操作。,2.3.1 元件电气图形符号库及管理,原理图中元件的电气图形符号存放在不同的元件电气图形库文件中,(如图2-10中的核心元件NPN三极管存放在哪一元件电气图形符号库中?),到哪里去找原理图中的元器件?,原理图编辑操作演示电路,在Protel99中,进行原理图编辑所需的元件电气图形符号均存放在,DesignExplorer99LibrarySch,子目录下不同数据库文件(.ddb)内。,1.元件库的概念及Protel99元件电气图形符号库的认识,DDB(DesignData Book的简称)文件,实际上是元件库文件包,,在DDB数据库文件内可能包含一个或多个.lib库文件。,Sim.ddb,:仿真测试用元件电气图形符号文件包,其中包含了28个.Lib元件电气图形符号库文件。,Miscellaneous Devices.ddb,:存放分立元件的电气图形符号,如电阻、电容、电感、二极管、三极管、电位器等。,集成电路芯片:,按制造商分类分别存放在各自的公司相应的数据库文件包内。,元件库文件包 举 例,集成电路芯片,元件库文件包 举 例,AMD Analog.ddb,:AMD公司模拟元件电气图形符号库。,Dallas Logic.ddb,:Dallas公司数字逻辑电路芯片的电气图形符号库。,Motorola Oscillator,.ddb,:,Motorola公司振荡器芯片元件库。,Altera Interface.ddb,:,Altera公司接口器件的电气图形符号库。,2.从元件库列表中选择当前库文件,打开元件库列表选择需要的库,元件库的装入与取消,当前元件库的元件列表,(1),在如图,2-4,所示的原理图编辑器窗口内,,单击,元件电气图形库列表窗下的“,Add/Remove,”按钮。,(2),在下图中的“,Change Library File List,”窗口内,单击“文件类型,(T),”列表下拉按钮,选择,.,ddb,文件类型。,举例:如何增加一个Sim.ddb?,图,2-11,更改元件库列表,protell99SE的更改元件库列表示意图,图,2-12,装入,Sim.ddb,元件电气图形符号数据库,当操作者无法确定待放置元件的电气图形符号位于哪一元件电气图形库文件时,怎么办?,可单击原理图编辑窗口(如图,2-4,所示)内元件列表窗口下的,“,Find,”按钮,;,3.如何确定元件所在库?,图,2-12,装入,Sim.ddb,元件电气图形符号数据库,查找,元件,图,2-13,查找原理图用元件电气图形符号,一定要确定查找,范围,输入要查找,的元件名,图,2-14,查找结果,查找结果,已经查找到的元件可以马上放到编辑区,RES,:电阻器(Resistor),CAP,:电容 器 (Capacitor),Electro,:电 解电容(Electrolysis Capacitor),Inductor,:电 感,常用元器件名称:,2.3.2 放置元件,1.放置元件的操作过程,(1)选择待放置元件所在的,电气图形库(,Miscellaneous Devices.lib,),作为当前使用的元件库。,(2)在元件列表内找出并单击所需的元件。,(3)放置所选定的元件。,如何放置元件?,图,2-15,在“元件列表”窗内选择目标元件,放置所选的,元件,图,2-16,从元件库中取出元件电气图形符号,此时元件处于激活状态,单击鼠标左键固定,然后再,单击鼠标右键或Esc键退出放置状态,;,图,2-17,在原理图编辑区内放置了,NPN,三极管电气图形符号,放置前可用,Tab键,可修改其属性,;,放置后双击元件可修改其属性,;,图,2-18,粘贴到编辑区内的电阻元件,由于,Protel99,具有连续放置功能,固定第一个电阻后,可以不断重复“,移动鼠标单击鼠标左键,”的方法放置剩余电阻,待完成了所有同类元件放置操作,再,单击右键(或按下,Esc,键)退出,,这样操作效率较高。,Protel99,可以很方便的连续放置同类元件,图2-19 放置了元件后的编辑区,2.,调整元件位置和方向,如果感到图中元件的位置、方向不合理,可通过如下方式调整:,方法一,:单击鼠标左键,选定目标元件,被选定的元件的四周将出现一个虚线框,如图,2-20,所示,然后:,移动鼠标调整位置。,按空格键:使选定对象沿逆时针方向旋转90度,。,按X键:左右对称,。,按Y键:上下对称,。,图,2-20,选定对象的周围出现虚线框,方法二:将鼠标移到目标元件上,,按下鼠标左键不放,,然后直接移动鼠标(或通过空格、X、Y键也能迅速移动或调整元件的方向),当元件调整到位后,松开左键即可。,3.删除多余的元件,当需要删除图中的某一个或某几个元件时,可通过如下方式实现:,方法一,:,选定需要删除的目标元件,,然后再按,Del,键,。,方法二,:,执行“Edit”(编辑)菜单下的“Delete”命令,,然后将光标移到待删除的元件上,单击鼠标左键即可迅速删除光标下的元件,然后单击鼠标右键退出删除状态。,注意:,执行了Protel99中的某一命令后,一般需要通过,单击鼠标右键,或按,Esc,键退出。,方法三,:当需要删除某一矩形区域内的多个元件时,最好单击“,主工具,”栏内的“,标记,”工具,然后将光标移到待删除区的左上角,单击鼠标左键,移动光标到删除区右下角,单击鼠标左键,标记待删除的元件;,然后执行“Edit”菜单下的“Clear”命令,。,4.修改元件选项属性,序号、封装形式、型号或大小,图2-19中元件电气图形符号上的“R?”、“C?”、“Q?”代表什么?,它们就是元件序号。在缺省状态下,元件序号用“R?”、“C?”、“Q?”、“U?”表示,这显然不是我们所期望的,因为图,2-10,中的,NPN,三极管的序号是,Q1,。,可以通过如下方法修改元件的序号、封装形式、型号(或大小)等元件选项属性。,图2-21 元件属性设置窗,元件属性设置窗(修改后),这是什么?,集成电路,:,DIP(双列直插),SIP(单列直插),SOP(小尺寸封装),PQFP(塑料四边引脚扁平封装),PLCC(塑料有引线芯片载体封装)等。,Protel99SE常用的元件封装形式,常用的,集成电路,封装形式举例,DIP14,SIP12,QFP44,PGA52X9,ILEAD14,分立元件,:电阻电容电感等其封装尺寸与元件大小、耗散功率、安装方式等有关。,如电阻器常用的封装形式是 AXIAL0.3AXIAL1.0;,普通二极管的封装形式是 DIOD0.4DIOD0.7;,小电解电容的封装形式一般是 RB.2/.4RB.5/1.0;,三极管的封装形式由其型号决定,有TO-39、TO-42、TO-54、TO-92A、TO-92B、TO-220等。,Protel99SE中常用的元件封装形式,其它器件可由实际器件的封装形式和尺寸来创建封装图!,常用的,分立元件,封装形式举例,AXIAL1.0,1206,DIOD0.4,RB.2/.4,TO-18,TO-92A,TO-92B,TO-3,TO-220,2.3.3 连线操作,完成元件放置及位置调整操作后,就可以开始连线,放置电气节点、电源及地线符号等操作。,在Protel99原理图编辑器中,原理图绘制工具,如,导线,、,总线,、总线分支、,电气节点,、,网络标号,等均集中存放在“画线”工具(Wiring Tools)中(如图2-24所示),放置完元件后如何连线?,图2-24 画线工具,画线工具,1.连线,单击画线工具中的导线工具(注意在连线时一定要使用“,Wiring Tools,”工具中的导线),,SCH,编辑器即处于连线状态。,将光标移到元件引脚的端点、导线的端点以及电气节点附近时,光标下将出现一个黑圆圈(表示电气节点所在位置),如图,2-25,所示。,图,2-25,元件引脚端点、导线端点的电气连接点,连线过程如下:,(1)单击导线工具。,(2)必要时按下,空格键,切换连线方式。,Protel99提供了:Any angle(任意角度)、45 Degree Start(45开始)、45 Degree End(45结束)、90 Degree Start(90开始)、90 Degree End(90结束)和Auto Wire(自动)六种连线方式,如图所示。,图2-26 连线方式示意图,(3)当需要修改导线选项属性(宽度、颜色)时,按Tab键调出导线属性设置对话窗,如图所示。,图,2-28,连线示范,选择“,45 Degree Start,”方式,可迅速生成如图(,a,)所示的以,45,开始的连线。,选择“,45 Degree End,”方式,可迅速生成如图(,b,)所示的以,45,结束的连线。,为了提高连线效率,应根据需要采用相应的连线方式,生成直角、45连线。如图2-29所示。,图,2-29,连线方式选择规则,2.删除连线,首先选中要删除的导线,(导线两端、转弯处将出现一个灰色的小方块),如图,2-30,所示,然后按下,Del,键,即可删除被选中的导线。,3.调整导线长短和位置,先使导线处于选中状态;然后将鼠标移到小方块上,单击左键,鼠标箭头立即变为光标形状;,图2-30 处于选中状态的导线段,图2-31 放置电气节点,2.3.4,放置电气节点,2.3.5 放置电源和地线,单击画线工具中的电源/地线工具,然后按下Tab键,调出电源/地线选项属性设置窗口,如图2-32所示。,电源和地,图2-32 电源/地线选项属性设置窗,很重要!,图2-33 显示芯片隐藏的电源、地线引脚,显示芯片隐藏的电源、地线引脚,注意:,如果电源、地线符号的网络标号与原理图中集成电路芯片电源引脚与地线引脚名称不一致,则会造成集成电路芯片的电源、地线引脚不能正确连接到电源和地线节点上。,当原理图中含有两块集成电路芯片的电源引脚或地线引脚名称不一致时,根据实际情况可采用如图2-34所示的连接方法。,图2-34 电源、地线处理方法,完成连线并放置电源/地线后,如图2-10所示的单管放大电路的,电原理图的绘制就完成了!,结果如图2-35所示。,图2-35 完成原理图编辑后的结果,在电路图编辑过程中以及结束后,单击主工具栏内的“存盘”工具或“File”(文件)菜单下的“Save”命令将正在编辑的电原理图文件保存在这个设计包内。,注意保存原理图文件,也可以用Save as,当原理图中含有集成电路芯片时,常用“总线”代替数条平行的导线,以减少连线占用的图纸面积。,但“总线”毕竟只是一种示意性连线,通过总线连接的元件引脚电气上并不相连,还需要使用“,总线分支,”、“,标号,”作进一步的说明。,2.3.6 总线、总线分支、网络标号工具的使用,1.放置总线(Place Bus),例如在如图2-37所示的电路中,当需要将IC1的P20P26引脚分别与IC3的A8A14相连时,除了平行导线外,也可以使用总线、总线分支以及标号来描述它们彼此的连接关系。,图,2-37,用导线连接的原理图,画总线与画导线的操作过程完全相同,:,放置总线(,Place Bus,),图,2-38,绘制一条总线后的结果,2.放置总线分支(Place Bus Entry),使用“总线”来描述元件连接关系时,一般还需要“总线分支(Place Bus Entry)”连接元件引脚或导线。,放置总线分支(,Place Bus Entry,),图,2-39,处于激活状态的总线分支,图,2-40,用总线和总线分支实现元件引脚间的连接,3.放置网络标号(Place Net Label),总线、总线分支毕竟只是一种示意性的连线,元件引脚之间的,电气连接关系,并没有建立,还需,要通过网络标号(Net Label)来描述,两条线段或线段与元件引脚,即两电气节点之间的连接关系。,在导线或引脚端点放置两个相同的网络标号后,导线与导线(或元件引脚)之间就建立了电气连接关系。,原理图中具有相同网络标号的电气节点均认为电气上相连,,这样可以使用网络标号代替实际的连线。,放置网络标号(,Place Net Label,),Tab,键进入网络标号选项属性设置,放置网络标号的操作过程如下:,输入网络标号,注意,:在放置网络标号时,网络标号电气节点一定要对准元件引脚端点或导线,否则不能建立电气连接关系;,网络标号可以是任意长度的字符串,但,当网络标号以“数字”结尾,,如用A8、D0或SD2等作为网络标号时,在放置了当前网络标号后,,网络标号会自动递增,;,这样在放置多个网络标号时,单击放置“网络标号”工具,并设置第一个网络标号名后,即可不断重复“移动单击”操作迅速放置剩余的网络标号,如图2-42所示。,图,2-42,用网络标号指示电气连接关系,如果原理图中的元件数目较多,使用实际导线连接显得很乱时,除了使用网络标号来表示元件引脚之间的连接关系外,还可以使用,I/O端口,描述导线与导线或元件引脚(,包括任何两个电气节点,)的连接关系,。,2.3.7 I/O端口的使用,放置,I/O端口,图,2-43,单击“,I/O,端口”工具后出现的,I/O,端口框,图,2-44 I/O,端口选项属性设置窗,图2-45 I/O端口形状,图2-46 用“I/O端口”指示电气连接关系,2.4 利用画图工具添加说明性图形和文字,2.4.1 画图工具介绍,如图所示画图工具,如直线(,Line,)、多边形(,Polygon,)、椭圆弧(,Elliptical Arcs,)、椭圆(,Ellipses,)、毕兹曲线(,Bezier,)等均存放在“画图”工具(,Drawing Tools,)栏内。,可执行“,View,”菜单下的“,ToolbarsDrawing Tools,”命令 打开画图工具窗(栏)。,图2-47 画图工具,注意与画线工具的区别,2.4.2 常见图形的绘制技巧,通过下面的几个实例介绍画图工具的基本使用方法,而绘图工具更详细的使用方法可参阅,2.12,节的内容(,Protel99,中所有元件的电气图形符号均使用画图工具绘制)。,利用直线、曲线、文字等画图工具在如图,2-35,所示的电路中添加如图,2-48,所示的,输入,/,输出信号波形的操作过程如下:,图2-48 输入/输出波形,单击画图工具(,Drawing Tools,)窗内的直线工具,,按下,Tab,键进入直线选项属性设置窗口,(如图,2-49,所示)。,选择线条粗细:(,Small,即小、,Smallest,即最小、,Medium,即中等、,Large,即粗)、形状,(Solid,即实线、,Dashed,即虚线、,Dotted,即点画线,),;,(1),绘,X,轴线段,图2-49 直线工具选项属性,(2),绘Y轴线段方法同上。,(3)利用同样方法,绘出X轴、Y轴的箭头,,然后单击右键或,Esc,键退出直线绘制状态。,(4)绘正弦波,单击画图工具(,Drawing Tools,)内的曲线工具,必要时按下,Tab,键进入曲线选项属性设置窗口,选择线条粗细、颜色。,图,2-50,正弦信号波形的绘制顺序,(6),一些常见曲线的绘制顺序如图,2-51,所示,图,2-51,常见曲线的绘制顺序,(7),单击画图工具(,Drawing Tools,)窗内的文本(,Place Annotation,)工具,按下,Tab,键进入文本选项属性设置窗口,,输入文本信息,(缺省时是最近一次输入的文本信息),设置文本的字体颜色、字体大小等选项后,单击“,OK,”按钮退出即可。,(8)将光标移到适当位置,单击鼠标左键固定文本信息即可。然后不断按下Tab键,输入,X,轴,、,Y,轴,单位、,坐标刻度,等文本信息。,利用同样方法制作输出特性曲线,最后就可获得如图,2-48,所示的输入、输出曲线。,2.5 原理图的编辑技巧,2.5.1 操作对象概念,在Protel99SE原理图编辑器中,,,画线、画图工具中的所有工具统称为操作对象,;,所有操作对象的性质相同或相近的,操作方式也相同或相近。掌握了其中某一个对象的操作方法,也就掌握了其他对象的操作方法。,2.5.2 单个对象的编辑,1.选定当前操作对象,将鼠标移到待选定的操作对象上,,单击鼠标左键即可将鼠标下的对象作为当前操作对象,。,当把画图工具中的直线,画线工具中的导线、总线以及总线分支等作为当前操作对象时,线段的起点、终点以及转弯处均出现一个灰色的小方块;,而将元件及其序号、型号以及网络标号、文本信息等操作对象作为当前操作对象时,其四周将出现一个虚线框,如图2-52所示。,图2-52 当前操作对象的状态,2.删除单个对象,将鼠标移到待删除对象上,单击鼠标左键,选定待删除的对象,然后按下Del键,即可将其删除。,但需要注意的是,:,不能单独删除元件序号、型号,原因是元件序号、型号是元件的组成部分,只有删除元件本身才能删除与元件关联的序号和型号。,3.移动,方法一:将鼠标移到需要平移的操作对象上,按住鼠标左键不放(鼠标箭头将变为光标),直接拖动对象到指定位置。,方法二:执行“,Edit,”菜单下的“,MoveMove”,或“,MoveDrag,”命令,然后将光标移到需要平移的对象上,单击鼠标左键,移动光标,可直接将操作对象移到另一位置,然后单击鼠标左键固定。,1.对象的标记及解除,对多个操作对象进行移动(平移)、旋转(包括对称)、删除、重新排列等操作之前,均需要标记参与操作的对象,以确定哪些对象将要参与相应的操作。标记操作对象的方法很多,如:,2.5.3 同时编辑多个对象,单击主工具栏的“标记”工具(与执行菜单命令“EditSelectInside Area”的效果相同)。,矩形框内的对象被选中,缺省状态下被选中对象显示为黄色,如图,2-54,所示。,方法一:,图2-53 矩形框的大小随鼠标的移动而移动,图2-54 被选中对象显示为黄色,方法二:直接按住鼠标左键不放,移动鼠标器,用矩形框覆盖所有待标记的对象后,松开左键,也可以迅速标记矩形框内的操作对象。,方法三:执行“EditToggle Selection”命令,使SCH编辑器处于选择命令状态,将光标移到待标记的对象上,单击鼠标左键选定(可以完成对多个对象的选定。,方法四:当需要选定矩形框外的操作对象时,可执行“,EditSelectOutside Area,”命令,然后将光标移到矩形框的左上角,并单击鼠标左键,再移动光标到矩形框的右下角,再单击鼠标左键。结果将发现矩形框外的对象全部被选中。,解除被选在一起的对象(即取消标记)的方法:单击主工具栏内的“解除”标记工具(与“Edit”菜单下的“DeSelectAll”命令等效),。,2.删除多个对象,标记后,执行“,Edit,”菜单下的“,Clear,”命令,即可一次性地删除已标记的多个对象,。,3.移动/拖动多个对象,标记后,单击主工具栏内的“移动选定对象”工具(与“Edit”菜单下的“MoveMove Selection”命令等效),将鼠标移到标记块内,单击左键,标记块即处于激活状态,然后就可以进行如下操作:,通过移动光标使标记块平移,然后单击鼠标左键固定。,按空格键使标记块旋转,按X、Y键使标记块关于左右、上下对称翻转。,在放置元件或其他图形的操作过程中,依靠手工调整元件位置,使元件或图形排列整齐不是一件容易的事,,可使用“,Edit,”菜单下的“,Align,”命令重新迅速、准确地调整元件或图形的位置,使元件靠左或右,上或下对齐。,4.元件及图件自动对齐,图2-55 使图件靠左重新排列的操作过程和结果,图,2-56,对水平方向排列图件实施靠左右排列结果,(a),执行靠左右排列命令前,沿水平方向排列的图件,(b),执行靠左右排列命令后,沿水平方向排列的图件重叠,3),沿水平方向靠中排列,元件或图形沿垂直方向排列,但各图件水平中心线不重合时,标记后,执行“Edit”菜单下的“AlignCenter Horizontal”命令,可使标记块内的图件水平中心线重合,最终使图件沿一条竖线分布,如图2-57所示。,图,2-57,使垂直排列的图件沿竖线排列,4),沿垂直方向靠中排列,元件或图形沿水平方向排列,但各图件垂直中心线不重合,标记后,执行“Edit”菜单下的“AlignCenter Vertical”命令,可使标记块内的图件垂直中心线重合,最终使图件沿一条水平线分布,如图2-58所示。,(a),(b),(c),图,2-58,使水平分布的图件垂直中心线重合,5),沿垂直方向均匀排列,元件或图形沿垂直方向排列,但各图件在垂直方向上的分布不均匀,如图,2-59(a),所示,可执行“,Edit,”菜单下的“,AlignDistribute Vertically,”命令,使标记块内的图件以上、下两图件为上、下边界沿垂直方向重新排列,操作过程如图,2-59,所示。,(1),调整并固定最上和最下两电阻的位置,以确定图件重新排列的间距,因为,垂直均匀分布操作的结果在不改变最上和最下两个元件位置的情况下,仅重新调整位于这两者之间的元件或图件位置,。,(2),标记待重新排列的图件,如图,2-59(b),所示。,(3),执行“,EditAlignDistribute Vertically,”命令,使标记块内的元件沿垂直方向均匀排列,操作结果如图,2-59(c),所示。,(4),单击主工具栏内的“解除标记块”工具,即可观察到如图,2-59(d),所示的最终结果。,(a)(b)(c)(d),图,2-59,使图件沿垂直方向均匀排列,6),沿水平方向均匀排列,元件或图形沿水平方向排列,但各图件在水平方向分布不均匀,如图,2-60(a),所示,可通过“,Edit,”菜单下的“,AlignDistribute Horizontally,”命令,使标记块内的图件以左、右两图件为左、右边界沿水平方向重新排列,操作过程如图,2-60,所示。,(1),调整并固定最左边和最右边两电阻的位置,以确定图件重新排列的间距,因为水平均匀分布操作的结果也不改变最左边和最右边两元件的位置,仅重新调整位于这两者之间的元件或图件位置)。,(2),标记待重新排列的图件,如图,2-60(b),所示。,(3),执行“,EditAlignDistribute Horizontally,”命令,使标记块内的元件沿水平方向均匀排列,操作结果如图,2-60(c),所示。,7),靠上或靠下重新排列沿水平分布的图件,元件或图形沿水平方向排列,但上、下不对齐,如图,2-60(a),所示,标记后,执行“,Edit,”菜单下的“,AlignAlign Top,”命令使标记块内的图件靠上对齐,或执行“,Edit,”菜单下的“,AlignAlign Bottom,”命令使标记块内的图件靠下对齐。,图2-60 使图件沿水平方向均匀排列,8),使图件同时沿水平方向和垂直方向重新排列,为了提高操作效率,可执行“,Edit,”菜单下的“,AlignAlign,”命令,在弹出的对话窗内,选定图件在水平方向和垂直方向上的排列方式,然后单击“,OK,”按钮,即可使图件沿水平方向和垂直方向重新排列。举例如下:,先选中要操作的对象:一组电阻,同时选定两个方向的排列方式,排列操作结果,撤销选择后的最后结果,在如图,2-61,所示电路中,当集成电路芯片,IC1,、,IC2,之间需要通过一组平行导线连接时,,怎样才能快速画出一组平行导线?,2.5.4 利用拖动功能迅速画一组平行导线,图,2-61 IC1,的,P00,P07,引脚与,IC2,的,D0,D7,引脚需要通过一组平行导线相连,首先,将,IC2,左移,使两芯片需要连接的引脚端点重叠,如图,2-62,所示。,然后,执行“,Edit,”菜单下的“,MoveDrag,”命令,将,IC2,平行右移,将发现原来重叠的引脚端点间出现了连线,如图,2-63,所示。,操作步骤:,图,2-62 IC2,左移使,IC1,与,IC2,引脚端点相连,图2-63 执行“Edit”菜单下的“MoveDrag”命令并将IC2右移,2.5.5 “画图”工具内“阵列粘贴”工具的特殊用途,下面以放置电阻,R201,R206,为例,介绍通过“画图”工具内的“阵列粘贴”工具放置一组元件的操作过程:,1.放置一组元件,图,2-65,设置并调整好第一个电阻,R201,阵列粘贴工具,先,选中,要复制的元件,执行“,copy,”,再执行“,clear,”,执行阵列粘贴工具,选择需要的元件个数,粘贴元件间的水平距离,粘贴元件间的垂直距离,图,2-66,“阵列粘贴”属性选项框,粘贴的效果,撤销选择后的最后粘贴结果,2.放置组合元件,图2-68 设置并调整好第一个电阻R201和第一个LED VD201,放置过程中可修改元件属性,用“块标记”工具选中组合元件,执行“Edit”下的“Copy”,并选中它,执行“Edit”下的“Clear,”,删除它,执行阵列粘贴工具,设置“阵列粘贴”属性选项框,最后执行“解除选中”工具,粘贴结果,粘贴效果,当需要画出一组平行导线时,除了可通过手工方式逐一绘制外,还可以通过“阵列粘贴”工具迅速绘出,效率也很高。,3.迅速画出一组平行导线,图,2-70,绘制第一条导线,然后选中该导线,执行“Edit”下的“Copy”命令,并选中它,确定参考点,然后执行“Edit”菜单内的“Clear”,执行阵列粘贴工具,设置“阵列粘贴”属性选项框,图,2-71,粘贴结果,2.6 元件自动编号,用“U?”作为集成电路芯片的元件序号;,用“R?”作为电阻元件序号;,用“C?”作为电容元件序号;,用“L?”作为电感元件序号;,用“D?”作为二极管类元件序号;,用“Q?”作为三极管类元件序号。,在放置元件操作过程中,如果没有在元件属性设置窗口内指定元件序号,Protel99将使用元件序号的缺省设置:,下面所示的电路为例,介绍元件重新编号的操作过程:,图,2-72,元件自动编号设置,(1)执行“Tools”菜单下的“Annotate”命令:,选择自动编号的方式,选择自动编号的路径,图,2-73 生成的,元件自动编号报告,(2)设置好自动编号条件后,单击“OK”按钮,启动元件自动编号进程,图,2-74,元件自动编号后,单一模块电路元件自动编号,这里所说的“单一模块电路”是指没有子电路系统的简单电路,且绘制在同一原理图内。这类电路中的元件序号信息仅包含元件类型和顺序号。,下面以图,2-75,所示的电源电路为例,介绍元件数在,1,99,之间的单一模块电路元件重新编号的过程。,图,2-75,元件自动编号之前,必要时,可执行“Tools”菜单下的“Annotate”命令,选项设为“,Reset Designators,”,使所有元件序号还原为缺省状态。,(1)可以执行“Tools”菜单下的“Annotate”命令,将“Annotate Options”选项设为“All Parts”,对所有元件序号重新编号。,在原理图编辑状态下,双击编号在,1,12,之间的任一电容(如,C1,),进入电容属性设置窗,并单击“,Global,”(全局选项)按钮,在如图,2-76,所示的窗口内修改电容全局选项。单击“,OK,”按钮,。,(2)如何将图中序号在C1C12之间的电容序号改为“C0?”(元件类型+0+?)形式?,图,2-76,元件全局属性窗口,然后执行“Tools”菜单下的“Annotate”命令,将“Annotate Options”选项设为“?Part”,对含有“?”的元件重新编号。,2.7 原理图的电气检查,在编辑原理图过程中,对于只有少量分立元件的简单电路,通过浏览就能看出电路中存在的问题,但对于一个较复杂的电路设计项目,靠人工查找电路编辑过程中的错误就没那么容易了。,以下面所示的原理图电路为例,介绍电气法测试的操作过程和结果:,图,2-82,电气法测试实验电路,(1),执行“,Tools,”菜单下的“,ERC,”命令。,(2),在如图,2-83,所示的对话框内,单击“测试项目”列表框内各
展开阅读全文