收藏 分销(赏)

SPSS统计分析前的准备.ppt

上传人:快乐****生活 文档编号:14643239 上传时间:2026-10-24 格式:PPT 页数:271 大小:4.78MB 下载积分:10 金币
下载 相关
SPSS统计分析前的准备.ppt_第1页
第1页 / 共271页
SPSS统计分析前的准备.ppt_第2页
第2页 / 共271页


点击查看更多>>
资源描述
,*,*,第,2,章,SPSS,统计分析前的准备,2.1,SPSS,数据文件的建立,SPSS,数据文件的建立可以利用,【,File,(,文件,)】,菜单中的命令来实现。具体来说,,SPSS,提供了四种创建数据文件的方法:,新建数据文件;,直接打开已有数据文件;,使用数据库查询;,从文本向导导入数据文件。,2.1.1,新建数据文件,打开,SPSS,软件后,现在菜单栏中的,【File(,文件,)】【New(,新建,)】【,Data,(,数据,)】,命令,可以创建一个新的,SPSS,空数据文件。接着,用户可以进行直接录入数据等后续工作。,值得注意的是,,SPSS19.0,可以同时打开多个数据文件,用户可以在多个文件中进行转换操作,这比起低版本的,SPSS,来说,更方便用户使用。,2.1.2,直接打开已有数据文件,打开,SPSS,软件后,现在菜单栏中的,【,File,(,文件,)】【,Open,(,打开,)】【,Data,(,数据,)】,命令,弹出,【,Open Data,(,打开数据,)】,对话框。选中需要打开的数据类型和文件名,双击打开该文件。,2.1.3,利用数据库导入数据,打开软件后,现在菜单栏中的,【,File,(,文件,)】【,Open Database,(,打开数据库,)】【,New Query,(,新建查询,)】,命令,弹出,【,Database Wizard,(,数据库向导,)】,对话框。通过这个数据库向导窗口,用户可以选择需要打开的文件类型,并按照窗口上的提示进行相关操作。,2.1.4,文本向导导入数据,SPSS,提供了专门读取文本文件的功能。打开软件后,现在菜单栏中的,【File(,文件,)】【Read Text Data(,打开文本数据,)】,命令,弹出,【,Open Data,(,打开数据,)】,对话框,。这里用户需要选择需要打开的文件名称,并且单击,【,Open(,打开,)】,按钮进入文本文件向导窗口。,2.1.4,文本向导导入数据,2.1.5,实例分析:股票指数的导入,2.1.5,实例分析:股票指数的导入,Step02,:,选定打开文件类型,在,【,Files of type,(,文件类型,)】,下拉列表框中指定打开,Excel,文件类型。接着,选择,2-1.xls,文件。最后单击,【,Open,(,打开,)】,按钮。,2.1.5,实例分析:股票指数的导入,2.1.5,实例分析:股票指数的导入,Step03,:,设置变量名称,弹出的对话框中的,【,Read variable names,from the first row of date(,从第一行数据,读取变量名,)】,复选框表示,SPSS,将,Excel,工作表的第一行设定为,SPSS,的变量名称,,【,Range,(,范围,)】,文本框表示选定,Excel,文件导,入,SPSS,的数据范围。这里,保持系统默认选项。,2.1.5,实例分析:股票指数的导入,2.1.5,实例分析:股票指数的导入,Step04,:,完成操作,最后,单击,【,OK(,确定,)】,按钮,数据即可导入成功。此时,,SPSS,的数据浏览窗口中会出现相关的数据内容。,2.1.5,实例分析:股票指数的导入,2.2 SPSS,数据文件的属性,一个完整的,SPSS,文件结构包括变量名称、变量类型、变量名标签、变量值标签等内容。用户可以在创建了数据文件后,单击数据浏览窗口左下方的,【,Variable View,(,变量视图,)】,选项卡,进入数据结构定义窗口。用户可以在该窗口中设定或修改文件的各种属性。,注意:,SPSS,数据文件中的一列数据称为一个变量,每个变量都应有一个变量名。,SPSS,数据文件中的一行数据称为一条个案或观测量(,Case,)。,2.2 SPSS,数据文件的属性,2.2.1,变量名:,Name,栏,变量名(,Name,),是变量存取的唯一标志。在定义,SPSS,数据属性时应首先给出每列变量的变量名。变量命名应遵循下列基本规则:,SPSS,变量长度不能超过,64,个字符(,32,个汉字);,首字母必须是字母或汉字;,变量名的结尾不能是圆点、句号或下划线;,变量名必须是唯一的;,变量名不区分大小写;,SPSS,的保留字不能作为变量名,例如,ALL,、,NE,、,EQ,和,AND,等;,如果用户不指定变量名,,SPSS,软件会以,“,VAR”,开头来命名变量,后面跟,5,个数字,如,VAR00001,、,VAR00019,等。,注意:为了方便记忆,用户所取的变量名最好与其代表的数据含义相对应。,2.2.2,变量类型:,Type,栏,变量类型是指每个变量取值的类型。,SPSS,提供了三种基本数据类型:数值型、字符型和日期型。,2.2.3,变量格式宽度:,With,栏,变量格式宽度,With,是指在数据窗口中变量列所占的单元格的列宽度,一般用户采用系统默认选项即可。值得注意的是,如果变量宽度大于变量格式宽度,此时数据窗口中显示变量名的字符数不够,变量名将被截去尾部作不完全显示。被截去的部分用,“,*,”,号代替。,2.2.4,变量小数位数:,Decimals,栏,【,Decimals Places,】,文本框可以设置变量的小数位数,系统默认为两位。,2.2.5,变量名标签:,Label,栏,变量名标签(,Label,)是对变量名含义的进一步解释说明,它可以增强变量名的可视性和统计分析结果的可读性。用户有时在处理大规模数据时,变量数目繁多,此时对每个变量的含义加以标注,有利于用户弄清每个变量代表的实际含义。变量名标签可用中文,总长度可达,120,个字符。同时该属性可以省略,但建议最好给出变量名的标签。,2.2.5,变量名标签:,Label,栏,2.2.6,变量值标签:,Values,栏,变量值标签,(,Values,),是对变量的可能的取值的含义进行进一步说明。变量值标签特别对于数值型变量表示非数值型变量时尤其有用。,定义和修改变量值标签,可以双击要修改值的单元格,在弹出的对话框的,【,Values,(,值,)】,文本框中输入变量值,在,【,Label,(,标签,)】,文本框中输入变量值标签,然后单击,【,Add,(,添加,)】,按钮将对应关系选入下边的白框中。同时,可以单击,【,Change,(,改变,)】,和,【,Remove(,移动,)】,按钮对已有的标签值进行修改和剔除。最后单击,【,OK,(,确定,)】,按钮返回主界面。,2.2.6,变量值标签:,Values,栏,2.2.7,变量缺失值:,Missing,栏,在统计分析中,收集到的数据可能会出现这样的情况:一是数据中出现明显的错误和不合理的情形;另一种是有些数据项的数据漏填了。,双击,【,Missing,(,缺失,)】,栏,在弹出的对话框中可以选择三种缺失值定义方式。,2.2.8,变量列宽:,Columns,栏,【,Columns,(,列,)】,栏主要用于定义列宽,单击其向上和向下的箭头按钮选定列宽度。系统默认宽度等于,8,。,2.2.9,变量对齐方式:,Align,栏,【Align(,对齐,)】,栏主要用于定义变量对齐方式,用户可以选择,Left,(,左对齐)、,Right,(右对齐)和,Center,(居中对齐)。系统默认变量右对齐。,2.2.10,变量测度水平:,Measure,栏,【,Measure,(,测度,)】,栏主要用于定义变量的测度水平,用户可以选择,Scale,(定距型数据),Ordinal,(定序型数据)和,Nominal,(定类型数据。,2.2.11,变量角色,:,Role,栏,【,Role,(,角色,)】,栏主要用于定义变量在后续统计分析中的功能作用,用户可以选择,Input,、,Target,和,Both,等类型的角色。,2.2.11,实例分析:员工满意度调查表的数据属性设计,1.,实例内容,为了提高员工的工作积极性,完善公司各方面管理制度,并达到有的放矢的目的,某公司决定对本公司员工进行不记名调查,希望了解员工对公司的满意情况。请根据该公司设计的员工满意度调查题目(行政人事管理部分)的特点,设计该调查表数据在,SPSS,的数据属,性。,2.,实例操作,具体步骤如下。,Step01,:,打开,SPSS,中的,Data View,窗口,录入或导入原始调查数据。,Step02,:,选择菜单栏中的,【,File,(,文件,)】【,Save,(,保存,)】,命令,保存数据文件,以免丢失。,Step03,:,单,SPSS,中的,【,Variable View,(,变量视图,)】,选项卡,按窗口提示进行数据属性的定义,如变量名称、标签、标签值等,。,3.,实例结果,2.3 SPSS,数据文件的整理,通常情况下,刚刚建立的数据文件并不能立即进行统计分析,这是因为收集到的数据还是原始数据,还不能直接利用分析。此时,需要对原始数据进行进一步的加工、整理,使之更加科学、系统和合理。这项工作在数据分析中称之为统计整理。,【Data(,数据,)】,菜单中的命令主要用于实现数据文件的整理功能。,2.3.1,观测量排序:地区生产总值分析,SPSS,操作详解,Step01,:,打开观测量排序对话框,打开,SPSS,软件,选择菜单栏中的,【,File,(,文件,)】【,Data,(,数据,)】【,Sort Cases,(,排序个案,)】,命令,弹出,【,Sort Cases,(,排序个案,)】,对话框。,Step02,:,选择排序变量,在左侧的候选变量列表框中选择主排序变量,单击右向箭头按钮,将其移动至,【,Sort by,(,排序依据,)】,列表框中。,Step03,:,选择排序类型,在,【,Sort Order,(,排列顺序,)】,选项组中可以选择变量排列方案。,Step04,:,单击,【,OK】,按钮,此时操作结束。,1.SPSS,操作详解,2.,实例内容:地区生产总值分析,地区生产总值是指某地区在一定时间内的国内生产总值,它可以作为衡量该地区经济发展的重要综合指标。随书光盘中的数据,2-3,.,sav,列出了,2005,年我国部分省份的地区生产总值及第一产业、第二产业和第三产业的生产总值,请根据这些数据分析不同省份经济发展状况的差异性。,Step01,:,选定对话框,打开,SPSS,软件,选择菜单栏中的,【,Data,(,数据,)】【,Sort Cases,(,排序个案,)】,命令,弹出,【,Sort,C,ases,(,排序个案,)】,对话框。,Step02,:,选择排序变量,在左侧的候选变量列表框中选择主排序变量,DQ,,单击右向箭头按钮,将变量选择进入,【,Sort by,(,排序依据,)】,列表框中。,Step03,:,选择排序类型,为了表示不同省份生产总值的差异,按照从高到低的排列顺序,这里点选,【,Descending,(,降序,)】,单选钮,表示观测值按照降序进行排序。,Step03,:选择排序类型,Step04,:,完成操作,最后,单击,【,OK,(,确定,)】,按钮,操作完成。此时,,SPSS,的数据浏览窗口中观测量的顺序发生改变。,2.3.2,数据的转置:国家财政分项目收入,1.,操作详解,Step01,:,打开转置对话框,打开,SPSS,软件,选择菜单栏中的,【,File,(,文件,)】,Data(,数据,)】【T,ranspose,(,转置,)】,命令,弹出,【,Transpose,(,转置,)】,对话框。,Step02,:,选择转置变量,在左侧的候选变量列表框中选择需要进行转置的变量,单击右向箭头按钮,将其移动至,【,Variable(s),(,变量,)】,列表框中。,Step03,:,新变量命名,从左侧的候选变量列表框中可以选择一个变量,应用它的值作为转置后新变量的名称。此时,选择该变量进入,【,Name Variable,(,名称变量,)】,列表框内即可。如果用户不选择变量命名,则系统将自动给转置后的新变量赋予,Var001,、,Var002,的变量名。,Step04,:,单击,【,OK】,按钮,操作结束。,注意:数据文件转置后,数据属性的定义都会丢失,因此用户要慎重选择本功能。,2.,实例内容:国家财政分项目收入,数据(,2-4.sav,),Step01,:选定对话框,Step02,:选择转置变量,Step03,:新变量命名,Step04,:完成操作,2.3.3,文件合并:固定资产投资,【,data,(,数据,)】【,Merge Files,(,合并文件,)】,菜单中有两个命令选项:,【,Add Cases,(,添加个案,)】,和,【,Add Variables,(,添加变量,)】,。,1.,观测量合并的,SPSS,操作详解,观测量合并要求两个数据文件至少应具有一对属性相同的变量,即使它们的变量名不同。具体步骤如下。,Step01,:,打开观测量合并对话框,选择菜单栏中的,【,File,(,文件,)】【,Data,(,数据,)】【,Merge Files,(,合并文件,)】【,Add Cases,(,添加个案,)】,命令,弹出,【,Add Cases,(,添加个案,)】,对话框,Step02,:,选择合并文件,点选,【,An external SPSS Statistics data file,(,外部,SPSS Statistics,数据文件,)】,单选钮,同时单击,【,Browse】,按钮,选中需要合并的文件,并指定文件路径,然后单击,【,Continue】,按钮。,Step03,:,选择合并方法。,Step04,:,单击,【,OK】,按钮,操作结束,。,2.,变量合并的,SPSS,操作详解,变量合并要求两个数据文件必须具有一个共同的关键变量(,Key Variable,),而且这两个文件中的关键变量还具有一定数量的相同的观测量数值。,Step01,:,打开变量合并对话框。,Step02,:,选择合并文件。,Step03,:,选择合并方法。,Step04,:,单击,【,OK】,按钮,操作结束。,3.,实例内容:固定资产投资文件的合并,已知,2-5-1.sav,、,2-5-2.sav,和,2-5-3.sav,中的数据,是北京、天津、河北等省市在,2005,年部分行业的固定投资额(亿元)数据,请完成以下问题。,问题一:,将,2-5-1.sav,和,2-5-2.sav,的数据文件纵向合并。,问题二:将,2-5-2.sav,和,2-5-3.sav,的数据文件横向合并。,Step01,:打开对话框(问题一),Step02,:选择合并文件,Step03,:选择合并方法,Step04,:建立指示变量,Step05,:完成操作,Step01,:打开对话框(,问题二,),Step02,:选择合并文件,Step03,:建立指示变量,Step04,:完成操作,2.3.4,数据分类汇总,:,城乡居民储蓄存款,对数据进行分类汇总就是按指定的分类变量值对所有的观测量进行分组,对每组观测量的变量求描述统计量,并生成分组数据文件。例如,将一个工厂的数据资料,按照该工厂的各个部门进行分组,并统计各个部门的人员年龄均值、方差等,这些工作就属于数据分类汇总的范畴。,1.,数据分类汇总的,SPSS,操作详解,分类变量(,Break Variable,):,它是对样本数据进行分类的变量,如按性别、民族、行业性质等进行分类汇总。这种变量可以为数值型或字符型变量。,汇总变量(,Aggregate Variable,):,利用源数据文件中的变量和相应的汇总函数产生的新变量名称及其表达式。这种变量必须要求为数值型变量。例如,按性别统计年收入的平均值,此时,“,性别,”,是汇总变量,,“,每人年收入,”,是源变量,,“,不同性别的年收入均值,”,就属于汇总变量。,Step01,:打开数据汇总对话框,打开,SPSS,软件,选择菜单栏中的,【,File,(,文件,)】【,Data(,数据,)】【,Aggregate,(,分类汇总,)】,命令,弹出,【,Aggregate Data,(,汇总数据,)】,对话框。,Step02,:,选择分类变量,在左侧的候选变量列表框中选择一个或多个变量作为分类变量,将其移入,【,Break Variable(s)(,分组变量,)】,列表框中。,Step03,:,选择汇总变量,在左侧的候选变量列表框中选择一个或多个变量作为汇总变量,将其移入,【,Summaries of Variable(s)(,变量摘要,)】,列表框中。,Step04,:选择汇总函数,在,【,Summaries of Variable(s)(,变量摘要,)】,列表框中可以选择相应汇总变量,此时可以单击下方的,【,Function】,按钮,打开如下图所示的对话框。,Step05,:添加变量标签,在,【,Summaries of Variable(s,)(,变量摘要,)】,列表框中可以选择相应汇总变量,此时可以单击下方的,【,Name and Label】,按钮,弹出如下图所示的对话框。,Step06,:,选择汇总结果保存方式,在,【,save(,保存,)】,选项组中可以选择汇总结果的保存方式。,Step07,:,大规模数据的排序选择,勾选,【,Options for Very Large Datasets,(,适用于大型数据集的选项,)】,复选框,可以对含有大规模数据的数据文件进行汇总之前的排序工作,这样能使得后续操作更有效率。,Step08,:,完成上述操作后,单击,【,OK】,按钮,操作结束。,2.,实例内容:城乡居民人民币储蓄存款,下图是我国部分省份,2004,年度城乡居民的人民币储蓄存款金额(年底余额,单位,:,亿元)。,Step01,:打开对话框,Step02,:,选择分类变量,从对话框左侧的候选变量列表框中选择,“,省份,”,变量作为分类变量,将其移入,【,Break Variable(s)(,分组变量,)】,列表框中。,Step03,:,选择汇总变量,从对话框左侧的候选变量列表框中选择,“,城镇储蓄,”,和,“,农户储蓄,”,作为汇总变量,将其移入,【,Summaries of Variable(s)(,变量摘要,)】,列表框中。由于这里主要是比较存款金额的高低水平,因此选择系统默认的平均值函数。,Step04,:,选择汇总结果保存方式,在,【Save(,保存,)】,选项组中点选,【Write a new data file containing only the aggregated variables】,单选钮,其目的是新建,aggr.sav,的外部数据文件保存汇总结果。,Step05,:,单击,【,OK,(,确定,)】,按钮,完成操作。,2.3.5,数据文件的拆分,Split,1.,数据分类汇总的,SPSS,操作详解,Step01,:打开数据拆分对话框,打开,SPSS,软件,选择菜单栏中的,【,File,(,文件,)】【,Data,(,数据,)】【,Split File,(,拆分文件,)】,命令,弹出,【,Split File,(,拆分文件,)】,对话框。,Step02,:,选择数据拆分方式。,Step03,:,选择拆分变量。,Step04,:,单击,【,OK】,按钮,操作结束。,注意:,拆分后的文件在保存之后,下次调用该文件时,拆分结果仍然有效。当不需要分组时,可以按上述操作,点选,【,Analyze all cases,,,do not create groups,(,分析所有个案,不创建组,)】,单选钮。,2.,实例内容:分行业职工平均工资,下图是,2005,年我国部分按细行业划分的职工平均工资,请根据不同的行业类型,对原始数据进行拆分,数据详见,2-7.sav,。,Step01,:打开对话框,Step02,:选择数据拆分方式,Step03,:选择拆分变量,Step04,:完成操作,2.3.6,选择数据:城市设施水平,1.,操作详解,Step01,:,打开数据选择对话框,打开,SPSS,软件,在菜单栏中选择,【,File(,文件,)】【,Data,(,数据,)】【,Select Cases,(,选择个案,)】,命令,弹出,【,Select Cases,(,选择个案,)】,对话框。,Step02,:选择数据选择方式,单击,【,If】,按钮时,会弹出如下图所示的对话框。,单击,【,Sample】,按钮,弹出如下图所示的对话框。,单击,【,Range】,按钮,弹出如下图所示的对话框。,Step03,:,选择输出方式,在,【,Select Cases,(,选择个案,)】,对话框的,【,Output,(,输出,),】,选项组中可以选择变量的输出方式。,Step04,:,单击,【,OK】,按钮,操作结束。,2.,实例内容:城市设施水平,数据文件,2-8.sav,中,是,2006,年我国部分地区城市设施水平指标,包括城市用水普及率、城市燃气普及率等。请根据这些原始数据,按照以下条件选择数据。,条件一:选择城市用水普及率和城市燃气普及率都大于,90%,的地区。,条件二:随机选取,10,个地区。,(条件一,),Step01,:打开对话框,Step02,:设置数据选择方式,点选,【,If condition is satisfied,(,如果条件满足,),】,选项,表示选择满足题目要求条件的观测量。同时单击,【,If】,按钮,弹出条件选择对话框。,Step03,:设置选择条件,Step04,:完成操作,条件二,条件二属于随机选择的问题,因此需要点选,【,Random samples of cases,(,随机个案样本,)】,单选钮,同时在弹出的,【,Select Cases,:,Random Sample(,选择个案:随机样本,)】,对话框的,“,Exactly,cases form the fiirst,cases”,文本框,中分别输入,10,和,31,,表示从,31,个观测量中选择,10,个观测量。最后,单击,【,Continue】,按钮返回主对话框,随机选取的样本结果如下页所示。,2.3.7,数据加权,:,蔬菜的平均价格,权重是数据分析中的一个重要概念,它是一个相对的概念。权重的大小描述了该指标在整体评价中的相对重要程度。在数据处理中,常需要对数据进行加权处理。,在记录有大量数据的文件中,可能同一观测量值会反复出现,如性别、民族等。如果在建立数据文件时能定义一个频数变量,也称为权重变量,用它来代表相同观测量出现的次数,这样后续的统计分析工作就会极大的简化。,1.,数据加权的,SPSS,操作详解,Step01,:,打开数据加权对话框,打开,SPSS,软件,选择菜单栏中的,【,File,(,文件,)】【,Data,(,数据,)】【,Weight cases,(,加权个案,)】,命令,弹出,【,Weight cases,(,加权个案,)】,对话框。,2.,实例内容:蔬菜的平均价格,某经销商希望掌握菜市场的蔬菜销销售的平均价格,收集数据见数据文件,2-9.sav,。现请利用这些数据,求出这些蔬菜的平均价格。,Step1,:,由于经销商要求掌握蔬菜的平均价格,如果仅仅只用蔬菜的单价进行简单的算术平均是很不合理的,这是因为不同蔬菜的销售量不同,所以要考虑销售量对平均价格的影响。因此,我们以蔬菜的销售量为权重计算各种蔬菜销售的平均价格更为合适。,这里选择,“,销售量,”,变量作为权重变量,将其放入,【,Frequencies Variable,(,频率变量,)】,列表框中,此时就可以进行后续的求平均值工作了。,Step02,:选择变量是否加权,用户首先选择是否对观测量进行加权。,Do not weight cases,:不对观测量加权,系统默认项。,Weight cases by,:对观测量加权,同时从左侧的候选变量列表框中选择权重变量移入,【,Frequency Variable,(,频率变量,)】,列表框中。,Step03,:,单击,【,OK】,按钮,操作结束。,2.4 SPSS,数据的计算和变换,在数据分析中,经常要根据一些已知的数据变量计算新的变量。例如,根据历年的产量数据资料计算产量的发展速度,根据人口数据计算人口出生率、死亡率等。不仅如此,还需要进行不同类型变量之间的转换,如将数值型变量转化为字符型变量。这些工作都需要利用,【,Transform(,转换,)】,菜单中的相关命令。,2.4.1,变量计算:国内生产总值的产业构成,变量计算是数据分析中的重要内容之一。有些时候,收集到的原始数据并不能直接提供给我们许多有用的信息,此时,我们需要将原始数据进行计算变换,生成有用的新的变量。例如,根据职工的基本工资、各类保险、公积金等,计算职工的实际月收入;根据购房客户的贷款总额和按揭方案评价客户的潜在风险等。,1.SPSS,操作详解,Step01,:,打开变量计算对话框,打开,SPSS,软件,选择菜单栏中的,【,File(,文件,)】【,Transform,转换,】【,Compute(,计算,)】,命令,弹出,【,Compute,(,计算,)】,对话框。,Step02,:定义新变量及其类型,在,【,Target Variable,(,目标变量,)】,文本框中用户需要定义目标函数名,它可以是一个新变量名,也可以是已经定义的变量名。单击下方的,【,Type&Label】,按钮,弹出类型和标签对话框。,Step03,:输入计算表达式,可以使用计算器板或键盘将计算表达式输入到,【,Numeric Expression,(,数值表达式,)】,文本中。如果用户需要调用函数,可以从右侧的,【,Function(,函数,)】,列表中选择,系统提供了数学函数、逻辑函数、日期函数等。,Step04,:条件样本选择,单击,【,If】,按钮,弹出的对话框如下图所示。,Step05,:结束操作,单击,【,OK】,按钮,此时操作结束。,2.,实例内容:国内生产总值的产业构成,数据文件,2-10.sav,为,我国,1978-2005,年国内生产总值、第一产业国内生产总值、第二产业国内生产总值和第三产业国内生产总值,请分析不同产业所占国内生产总值的变动情况。,Step01,:打开对话框,Step02,:,定义第一产业比重变量,在,【,Target Variable,(,目标变量,)】,文本框中定义目标函数名为,“,a”,,它表示第一产业生产总值所占总产值的比重。,Step03,:,计算第一产业生产总值所占比重,在,【,Numeric Expression,(,数值表达式,)】,文本框中输入计算表达式,“,a=,第一产业,/,国内生产总值,”,。,Step04,:完成操作,单击,【,OK(,确定,)】,按钮,操作完成。此时,原数据文件新增加了,“,a”,变量。,2.4.2,变量重新赋值:空气质量等级划分,SPSS,的,【,Transform,(,转换,)】,菜单中有,【,Recode into Same Variable,(,重新编码为相同变量,)】,和,【,Recode into Different Variable,(,重新编码为不同变量,)】,两个命令可以实现重新赋值功能,它们分别表示重新赋值到同一变量或不同变量。,下面以,【,Recode into Different Variable,(,重新编码为不同变量,)】,命令为例说明重新赋值功能。,1.SPSS,操作详解,Step01,:,打开重新赋值对话框,选择菜单栏中的,【,File,(,文件,)】【,Transform,(,转换,)】【,Recode into Different Variable,(,重新编码为不同变量,)】,命令,弹出如下图所示的对话框。,Step02,:选择重新赋值变量和输出变量,在候选变量列表框中选择要重新赋值的变量,将其移入,【,Input Variable-Output,V,ariable,(,输入变量,-,输出变量,)】,列表框中,同时在,【,Output Variable,(,输出变量,)】,选项组中填写输出变量的名称,【,Name,(,名称,)】,及标签,【,Label,(,标签,)】,,单击,【,Change】,按钮进行赋值转换。,Step03,:设置重新赋值规则,【,Old and New Value,】,按钮被激活,单击此按钮,弹出如下图所示的对话框。,Step04,:,选择样本赋值,如果用户不是对所有的候选变量进行赋值,而是选择其中符合某些条件的变量值进行赋值操作,此时需要单击,【If】,按钮进行操作。按照具体要求指定观察量的选择条件进行操作。,Step05,:,最后单击,【,OK】,按钮,此时操作结束。,2.,实例内容:空气质量等级的划分,下,图是我国部分城市,2005,年空气质量的指标数据(见数据文件,2-11.sav,),请利用这个规则对不同城市的空气质量等级进行划分。,Step01,:打开对话框,Step02,:选择重新赋值变量和输出变量,在左侧的候选变量列表框中选择,“,天数,”,变量进入,【,Input Variable-Output Variable,(,输入变量,-,输出变量,)】,列表框,同时在,【,Output Variable,(,输出变量,)】,文本框中,填写输出赋值变量名称,“,等级天数,”,,同时单击,【,Change】,按钮进行赋值转换。进行上述操作后,单击,【,Old and New Value,】,按钮。,Step03,:设置赋值规则,Step04,:完成操作,2.4.3,变量值计数:消费价格指数的上涨项目,数据分析中,常常需要计算一些变量在同一个观测量中满足要求的特定变量值出现的次数。例如在进行产品市场调查时,要了解在所有的调查客户中有多少人使用过该产品,这就可以采用变量值计数功能来实现。,1.SPSS,操作详解,Step01,:,打开重新赋值对话框,打开,SPSS,软件,选择菜单栏中的,【,File,(,文件,)】【,Transform,(,转换,)】【Count,Values within Cases,(,对个案内的值计数,)】,命令,弹出,【,Count Occurrences of Values within Cases,(,计算个案内值的出现次数,)】,对话框。,Step02,:,输入目标计数变量,在,【,Target Variable,(,目标变量,)】,文本框中输入需要计数的变量名称,同时在,【,Target Label,(,目标标签,)】,文本框中填写计数变量的标签,便于注释说明。,Step03,:,选择计数变量,在左侧的候选变量列表框中选择计数变量,将其移入右侧的,【,Variables,(,变量,)】,列表框中。需要注意,凡移入该列表框的变量必须具有相同的类型,当移入变量为数值型变量时,该栏标题改为,“,Number Variables”,;当移入变量为字符型变量时,标题改为,“,String Variables”,。,Step04,:设置计数规则,进行上述操作后,,【,Define Values】,按钮,被激活,单击此按钮,弹出如下图所示的对话框。,Step05,:,选择样本计数,如果用户不是对所有的候选变量进行计数,而是选择其中符合某些条件的变量值才进行计数操作,此时需要单击,【If】,按钮,按照具体要求指定观察量的选择条件进行操作。,Step06,:,最后单击,【,OK】,按钮,此时操作结束。,2.,实例内容:消费价格指数的上涨项目,我国城市和农村居民消费价格分类指数数据见数据文件,2-12.sav,。由于不同产品的价格涨跌不同,请找出城市和农村居民消费价格指数都较去年上涨超过,1%,的项目。,Step01,:打开对话框,Step02,:输入目标计算变量,在,【,Target Variable,(,目标变量,)】,文本框中输入需要计数的变量名称,“,x”,,同时在,【,Target Label,(,目标标签,)】,文本框中填写标签,“,增加率,”,。,Step03,:选择计数变量,Step04,:设置计数规则,Step05,:完成操作,2.4.4,观测量求秩:对外直接投资净额,“,秩,”,(,Rank,)是数据整理中的重要概念,前面讲解的观测量排序是按照大小顺序重新排列观测量,而观测量求秩是指对观测量排序后指定的,“,名次,”,。例如,观测量的值依次为,3,、,5,、,-2,、,0,、,7,,它们按小到大排列后为,-2,、,0,、,3,、,5,、,7,,各观测量的秩等于,3,、,4,、,1,、,2,、,5,。,1.SPSS,操作详解,Step01,:,打开观测量求秩对话框,打开,SPSS,软件,选择菜单栏中的,【,File(,文件,)】【,Transfo,r,m,(,转换,)】【,Rank Cases,(,个案排秩,)】,命令,弹出,【,Rank Cases,(,个案排秩,)】,对话框。,Step02,:,选择求秩变量,在左侧的候选列表框中选择求秩变量,将其移入,【,Variable(s),(,变量,)】,,此时系统会产生一个新的秩变量,它是在该变量的前面添加,“,r,”,而构成。,Step03,:,选择求秩顺序,【,Assign Rank 1 to(,将秩,1,指定给,)】,选项组用于指定求秩顺序。,Step04,:,选择分组变量,在左侧的候选变量列表框中选择分组变量,将其移入,【,By,(,排序标准,)】,列表框,此时,SPSS,会按所选的分组变量来求秩,如果不设定本选项,将对所有的观测量排秩。,Step05,:,选择汇总表输出,勾选,【,Display summary tables,(,显示摘要表,)】,复选框,系统将在输出窗口中显示概况原变量和新变量的摘要信息表。,Step06,:,秩类型选择,单击,【,Rank Types】,按钮,在弹出的对话框中可以选择秩的类型,。,Step07,:,Ties,(结)类型选择,单击,【,Ties】,按钮,在弹出的对话框中用户可以选择结类型。,Step08,:,最后单击主对话框中的,【OK】,按钮,此时操作结束。,2.,实例内容:对外直接投资净额分析,2005,年我国对主要国家(地区)对外直接投资金额(非金融类)的原始数据见数据文件,2-13.sav,,请按照区域类型不同对投资净额排秩。,Step01,:打开对话框,Step02,:选择求秩变量,Step03,:选择分组变量,在左侧的候选变量列表框中选择分组变量,“,区域,”,,将其移入,【,By(,排序标准,)】,列表框,此时,SPSS,会按它进行分组求秩。,Step04,:选择求秩顺序,Step05,:完成操作,第,3,章,SPSS,描述性统计分析,统计分析的目的是研究总体的数量特征。为实现上述分析,往往采用两种方式实现:第一,数值计算,即计算常用的基本统计量的值,通过数值来准确反映数据的基本统计特征;第二,图形绘制,即绘制常见的基本统计图形,通过图形来直观展现数据的分布特点。通常,这两种方式都是混合使用的。,SPSS,的许多模块均可完成描述性分析,但专门为该目的而设计的几个模块则集中在,【Descriptive Statistics】,菜单中。最常用的是列在最前面的四个过程。,Frequencies,:产生频数表。,Descriptives,:进行基本的统计描述分析。,Explore,:探索性分析。,Crosstabs,:列联表分析。,3.1 SPSS,在频数分析中的应用,1.,使用目的,频数分布表是描述性统计中最常用的方法之一。它主要能够了解变量取值的状况,对把握数据分布特征非常有用。例如,了解某班学生考试的学习成绩、了解某地区居民的收入水平等都可以借助于频数分析。,3.1.1,频数分析的基本原理,2.,软件使用方法,Frequencies,过程就是专门为产生频数表而设计的。它不仅可以产生详细的频数表,还可以按要求给出某百分位点的数值以及常用的条图、饼图等统计图。同时,,SPSS,的频数分析还可以进行分位数、描述集中趋势的基本统计量等计算功能。这些统计量的具体分析会在以后章节中讲解。,3.Bootst
展开阅读全文

开通  VIP、SVIP  下载更划算
下载10份以上建议开通 VIP 会员
下载20份以上建议开通SVIP会员


开通VIP      成为共赢上传

当前位置:首页 > 包罗万象 > 大杂烩

移动网页_全站_页脚广告1

关于我们      便捷服务       自信AI       AI导航        关注我们

©2010-2026 宁波自信网络信息技术有限公司  版权所有

客服电话:0574-28810668  投诉电话:18658249818

gongan.png浙公网安备33021202000488号   

icp.png浙ICP备2021020529号-1  |  浙B2-20240490  

关注我们 :微信公众号    抖音    微博    LOFTER 

客服