资源描述
,单击此处编辑母版标题样式,单击此处编辑母版文本样式,第二级,第三级,第四级,第五级,*,印制电路板的设计与制造,单击此处编辑母版标题样式,单击此处编辑母版文本样式,第二级,第三级,第四级,第五级,*,项目,1,单面,PCB,的设计与制作,任务,1,绘制扩音机原理图,印制板电路板的设计与制造,任务,1,绘制扩音机原理图,1.1,认知,Altium Designer Summer 09,设计环境,1.2,原理图绘制软件的使用,1.3,绘制扩音机原理图,1.1,认知,Altium Designer Summer 09,设计环境,软件的组成,1,Altium Designer,软件发展历程,1985,年 诞生,dos,版,Protel,1991,年,Protel for Widows,1997,年,Protel98,这个,32,位产品是第一个包含,5,个核心模,块的,EDA,工具,1999,年,Protel99,构成从电路设计到真实板分析的完整体,系。,2000,年,Protel99se,性能进一步提高,可以对设计过程有更,大控制力。,2002 年 Protel DXP 集成了更多工具,使用方便,功能更强,大。,2003 年 Protel 2004 对Protel DXP进一步完善。,2006 年 Altium Designer 6.0成功推出,集成了更多工具,,使用方便,功能更强大,特别在PCB设计这一块性能大大,提高。,年 Altium Designer Summer 8.0 将ECAD和MCAD两种文件格式结合在一起。,年 Altium Designer Winter 09推出。,年7月 Altium Designer Summer 09 为适应日新月异的,电子设计技术,Altium于 年7月在全球范围内推出最新版,本Altium Designer Summer 09。Summer 09的诞生延续了,连续不断的新特性和新技术的应用过程。,2.Altium Designer Summer 09,的组成,原理图设计系统(,SCH,),主要用于电路原理图的设计,为印刷电路板的制作进行前期的准备工作,主要表现了电路的原理连接,相对比较直观。,印制电路板设计系统(,PCB,),这部分系统则主要用于印刷电路板的设计,印刷电路板的生产车间就是根据由它生成的,PCB,文件进行,PCB,板的生产。,FPGA,系统,用户可以用该系统进行可编程逻辑器件的设计,并将设计完成之后生成的熔丝文件记录到逻辑器件中,即可制作具备特定功能的元器件。,VHDL,系统,主要用来进行硬件的编程工作。,3.Altium Designer Summer 09,的功能,(,1,)电路原理图设计,绘制和编辑电路原理图;,制作和修改原理图元件符号或元件库;,生成原理图与元件库的各种报表。,(,2,)印制电路板设计,印制电路板设计与编辑;,元件的封装制作与管理;,板型的设置与管理。,(,3,)电路的仿真,(,4,)可编程逻辑电路设计系统,(,5,)信号完整性分析,主窗口,用鼠标双击桌面的,图标,启动,Altium Designer Summer09,后便可进入主窗口,如图,1-1,所示。用户可以用该窗口进行文件操作。用户可以使用该窗口进行项目文件的操作,如创建项目、打开文件等。,主窗口主要包括,6,个部分,分别为菜单栏、工具栏、工作窗口、工作面板、面板控制栏及导航栏。,图,1-1,主窗口,1.,菜单栏,如图,1-2,所示,包括,1,个用户配置按钮,及,“,File”,(文件)、,“,View”,(视图)、,“,Project”,(项目)、,“,Window”,(窗口)和,“,Help”,(帮助),5,个菜单。,(,1,)用户配置按钮,此菜单用于系统的配置,(,2,),“,File”,(文件)菜单,图,1-2,菜单栏,此菜单主要用于文件的新建、打开和保存。,(,3,),“,View”,(视图)菜单,此菜单用于工具栏、工作窗口面板、命令行以及状态栏的显示和隐藏。,(,4,),“,Project”,(项目)菜单,此菜单主要用于项目文件的管理,包括项目文件的编译、添加、删除、显示项目文件的不同点和版本控制等命令。,(,5,),“,Window”,(窗口)菜单,用于对窗口进行纵铺、横铺、打开、隐藏以及关闭等操作。,(,6,),“,Help”,(帮助)菜单,用于打开各种帮助信息。,2.,工具栏,主工具栏有,3,个按钮,,分别是新建一个文件、打开已存在的文件和打开设备视图页面。,3.,工作窗口,图,1-6,工作窗口的,“,Home Page”,(主页)视图,4.,工作面板,使用工作面板是为了便于设计过程,中的快捷操作。,Altium Designer,Summer 09,启动后,系统将自动,激活,“,File”,(文件)面板、,“,Project”,(项目)面板、和,“,Navigator”,(导航)面板。可以单击面板底部,的标签在不同的面板之间进行切换。,文件管理系统,1,项目文件,Altium Designer Summer,09,支持项目级别的文件管,理,在一个项目文件里包,括设计中生成的一切文件。,2,自由文件,独立于项目文件之外,的文件,。,项目文件的操作,1,项目文件的创建,方法:,单击图,1-1,所示的“,File”,(文件)菜单“,New”,(新建)“,Project”,(项目)“,PCB Project”,(印制电路板项目);,在图,1-10,所示的“,Project”,(项目)面板中将出现一个新的,PCB,项目文件,“,PCB Project1”,为新建,PCB,项目默认名称,执行项目命令菜单中的,执行项目命令菜单中的“,Save,Project As”,(项目另存为),,则弹出“项目另存为”对话框。,选择保存路径并输入项目名称,“,MYEX1.PrjPCB”,,单击保存,按钮后,即可建立,PCB,项目,MYEX1,的文件夹,。,2.,项目文件的打开,具体步骤是:,单击图,1-1,所示的“,File”,(文件)菜单,“,Open Project”,(打开项目文件),在弹出的对,话框中选择要打开的项目的路径,找到要打开的项,目文件后,单击“,OK”,按钮即可。,3,项目文件的关闭,具体步骤,:,鼠标右键单击要关闭的项目文件,在他,弹出的菜单中选择“,Close Project”,(关闭项目文,件)即可。,1.2,原理图编辑器的基本用法,原理图设计流程,1,电路原理图的概念,电路原理图是指电路中各个元器件的电气连接关系的图纸。,2,原理图的设计流程,原理图绘制的基本流程如图,1-12,所示。,图,1-12,原理图绘制流程,启动原理图编辑器,1,、创建原理图文件,方法一:,执行“,File”,(文件)菜单“,New”,(新建)“,Schematic”,(原理图)创建原理图文件。,方法二:,用鼠标右键单击项目文件名,在弹出的菜单中选择“,Add New to Project”,(添加新文件到项目)“,Schematic”,(原理图)新建原理图文件。,2,、保存,用鼠标右键单击原理图文件“,Sheet1.SchDoc”,,在弹出的菜单中选择,Save As,,屏幕弹出一个对话框,将文件改名为“稳压电源”并保存。,设置图样参数,方法一:双击图样边框,方法二:执行菜单“,Design”“Document Option”,文档选项选中“,Sheet Option”,选项卡进行图样设置。,图纸尺寸,加、卸载元器件库,单击原理图编辑器右侧的“,Libraries”,(元器件库)标签,弹出元器件库面,板。,单击“,Libraries”,按钮,弹出下面的,对话框。,单击“,Install”,按钮,屏幕弹出“打开”元件库对话,框,选中元件库,单击打开完成元器件库的加载。,添加库按钮,放置元器件,1,、元器件放置,(,1,)通过元器件库控制面板放置元器件,打开,“,Libraries”,面板,加载,Miscellaneous Device.IntLib,库。在元器件列表中找到,2N3904,单击,“,Place 2N3904”,按钮,将光标移动到工作区中,此时元器件以虚框的形式粘在光标上,将此元件移动到合适位置,再次单击鼠标,元器件就放置到图纸上了,如图,1-21,所示。,(,2,)通过菜单放置元器件,执行菜单,“,Place”,(放置),“,Part”,(元件),系统弹出如图,1-22,所示对话框,在该对话框中,,可以设置放置元件的有关属性。,图,1-22 “Place Part”,对话框,2,元器件属性编辑,当元器件处,于虚框状态,时,按键盘,上的,Tab,键,,系统弹出元,件属性对话,框,如右图,所示此时可,以修改元件,的属性。,放置电源和地符号,执行菜单命令“,Place”,(放置)“,Power Port”,(电源端口),或单击布线工具栏上的第,5,个按钮,或第,6,个按钮 ,然后按,Tab,键打开电源端口属性,对话框,。,(项目)面板、和“Navigator”,PCB_ Project1.,1 认知Altium Designer Summer 09设计环境,照图1-38所示,去除有关驱动信号源和额外引脚,印制板电路板的设计与制造,1991 年 Protel for Widows,此菜单主要用于项目文件的管理,包括项目文件的编译、添加、删除、显示项目文件的不同点和版本控制等命令。,Project As”(项目另存为),,用户可以使用该窗口进行项目文件的操作,如创建项目、打开文件等。,若此时按下键,系,Options打开“Options for PCB Project”对话框,按,连线,单击连线工具栏的 按钮,光标变为“,”,形,,系统处于绘制导线状态。若此时按下,键,系,统会弹出导线属性,可以修改导线的颜色和粗细。,将光标移至所需位置,单击鼠标左键,定义导线,起点,将光标移至下一位置,再次单击鼠标左键,,完成两点连接,如图,1-28,所示。单击鼠标右键,则,退出画线状态。,编译及错误检查,对于简单电路,通过自己浏览就能看出电路中存,在的错误,但对于复杂电路的电路原理图,单靠观,察是不太可能查找到电路编辑过程中的所有错误。,为此,Altium Designer,提供了编译和检错的功能,执,行编译后,系统会自动在原理图中有错误的地方加,以标记,从而方便用户检查错误,提高设计质量。,对原理图进行编译,也叫,ERC,(,Electrical Rule,Check,)。在进行,ERC,之前,根据需要可以对,ERC,规则进行设置。,1.3,绘制扩音机原理图,图,1-31,新建原理图文件,执行菜单命令,FileNew,ProjectPCB Project,,系统自,动建立了一个名为,PCB_ Project1.PrjPcb,的项目文,件。然后在此文件名上单击鼠标右键,在弹出的菜,单中选择,Save Project,,将项目文件命名为:扩音,机,.PrjPcb,,并保存在指定文件夹下。,图,1-31,执行菜单命令,File New Schematic,创建原理,图文件。系统在扩音机项目文件夹下建立了原理图,文件,Sheet1.SchDoc,并进入原理图设计界面。用鼠,标右键单击原理图文件,“,Sheet1.SchDoc”,,在弹出的,菜单中选择,Save,,屏幕弹出一个对话框,将文件改,名为,“,扩音机,”,并保存在与项目文件相同的文件夹下。,设置图样、加载元器件库,1.,设置图样参数,图,1-32,图样参数设置,2.,加载元器件,按照前面元器件库的添加方法,在原有元件库的,基础上添加,Altium Designer Summer 09,安装目录下,LibrayTexas Instruments TI Operational,Amplifier.IntLib,和,LibrayMotorolaMotorola Power,Mgt Voltage Regulator.IntLib,两个集成元件库。,绘制扩音机电源电路,按照表,1-1,进行元器件参数设置,其中封装未列入,表中,按元器件自身默认封装设置。,Designator(,编号,),Comment(,注释,),LibRef(,参考库,),Quantity(,数量,),C1,4700uF,Cap Pol2,1,C2,C3,105,Cap,2,C4,470uF,Cap Pol2,1,D1,D2,D3,D4,1N4007,Diode 1N4007,4,U1,MC7812ACT,MC7812ACT,1,表,1-1,1.,放置扩音机电源元器件,2.,连线,绘制扩音机功率放大电路,Designator(,编号,),Comment(,注释,),LibRef(,参考库,),Quantity(,数量,),C5,C6,C7,C8,105,Cap,4,C10,C11,C14,C15,470uF,Cap Pol2,4,C9,C13,10uF,Cap Pol2,2,C12,C16,104,Cap,2,D5,D6,D7,D8,1N4148,Diode 1N4148,4,LS1,LS2,Speaker,Speaker,2,P1,P2,BNC,BNC,2,Q1,Q4,2SC1815,2N3904,2,Q2,Q5,TIP41,2N3904,2,Q3,Q6,TIP42,2N3906,2,R1,R5,R6,R10,1K,Res2,4,R2,R3,R7,R8,R11,R18,10K,6,R4,R9,100K,2,R12,R19,2K,2,R13,R24,1,2,R14,R20,47K,2,R17,R25,10,2,R15,R16,R22,R23,0.5,4,U2,NE5532JG,NE5532JG,1,VR1,VR2,50K,RPot,2,VR3,22K,1,VR4,VR5,50K,2,表,1-2,以标记,从而方便用户检查错误,提高设计质量。,用户可以使用该窗口进行项目文件的操作,如创建项目、打开文件等。,原理图设计系统(SCH)主要用于电路原理图的设计,为印刷电路板的制作进行前期的准备工作,主要表现了电路的原理连接,相对比较直观。,PCB_ Project1.,1985 年 诞生 dos 版 Protel,(1)通过元器件库控制面板放置元器件,1991 年 Protel for Widows,“Open Project”(打开项目文件),在弹出的对,Options打开“Options for PCB Project”对话框,按,绘制扩音机功率放大电路,然后在此文件名上单击鼠标右键,在弹出的菜,D1,D2,D3,D4,元件的封装制作与管理;,FPGA系统用户可以用该系统进行可编程逻辑器件的设计,并将设计完成之后生成的熔丝文件记录到逻辑器件中,即可制作具备特定功能的元器件。,表中,按元器件自身默认封装设置。,Project As”(项目另存为),,PCB_ Project1.,行编译后,系统会自动在原理图中有错误的地方加,按照图,1-31,放置功率放大电路的元器件,按照表,1-2,进行元器件参数设置,其中封装未列入表中,按元,器件自身默认封装设置。,编译及错误检查,按照前述方法对所绘制的原理图进行编译,检查,其中的错误。执行菜单命令,Project Project,Options,打开,“,Options for PCB Project”,对话框,按,照图,1-38,所示,去除有关驱动信号源和额外引脚,显示模式的违规信息,可以将它们设置为“,No,Report,”,(无报告)。,图,1-38,电气规则检查设置,
展开阅读全文