资源描述
*,*,*,Click to edit Master title style,单击此处编辑母版标题样式,单击此处编辑母版文本样式,第二级,第三级,第四级,第五级,*,第10章 应用程序开发实例,10.1 应用程序开发实例分析,本章将以一个图书管理系统为实例,从需求分析、项目创建、模块设计、运行调试、保存发布到建立帮助,对整个应用程序开发过程进行详细地说明,描述使用Visual FoxPro开发应用系统的大致流程。通过该实例的介绍,使读者对Visual FoxPro有更加全面、深刻的理解,从而为用户的实际工作带来参考价值。,10.1.1 系统需求分析,针对这些功能,我们通过调查研究归纳出目标系统的数据需求以及功能需求如下。,1)数据需求:通过调查,总结出该应用程序对数据的需求大致有如下这些:,(1)图书信息:包括图书的书号、作者编号、书名、价格、数量、出版社等信息。,(2)作者信息:包括作者编号、作者姓名、职称、联系 、备注、照片等信息。,(3)读者信息,主要包括读者编号、读者姓名、性别、出生日期、民簇、籍贯、联系 、照片等内容。,1)借阅信息:包括读者编号、读者姓名、书号、借书日期、还书日期等。,用户表:读者编号、用户名、密码等。,2)功能需求:功能分析的任务是了解用户对数据的处理方法和输出格式。,(1)基础数据录入,基础数据包括图书数据、作者数据、读者数据、图书借阅数据以及用户数据等。要求系统能够录入这些数据,并且可以进行修改。在数据录入和修改过程中应保持数据的参照完整性。,(2)查询:能够查询出图书数据、作者数据、读者数据、以及图书借阅数据等。,(3)读者服务:要求能够根据读者的实际需要进行借书和还书服务等。,(4)打印输出:打印图书清单和图书借阅情况表等。,10.1.2 系统设计,1)程序总体结构设计,在开始程序设计之前,首先应该将程序的总体结构以层次图的形式表示出来,便于对程序分层设计和实现。,2)数据库逻辑设计,进行数据库设计的依据有三个:第一是在进行系统调查时由图书馆提供的各种处理数据;第二是功能设计结果;第三是数据库设计规范化理论。数据库设计是系统设计的一项基本工作,其效果的好坏,对后续设计、调试、使用、维护等工作关系极大,因此,一定要高度重视这一部分工作。,(1)建立E-R图,首先,我们用前面曾经提到的E-R图这种直观的图形方式来建立图书管理系统中相关实体及其联系的模型。,(2)根据对E-R图进行分析建立关系模型,图书(书号、作者编号、书名、价格、数量、出版社),作者(作者编号、作者姓名、职称、联系 、备注、照片),读者(读者编号、读者姓名、性别、出生日期、民簇、籍贯、联系 、照片),借阅信息(读者编号、读者姓名、书号、借书日期、还书日期),用户表(读者编号、用户名、密码),10.1.3 创建项目,Visual Foxpro推荐在项目管理器中开发应用程序,因为项目管理器会为开发工作带来很多方便。在项目管理器中创建一个项目后,应用程序就具备了一个开发框架,然后在这个框架中,再利用项目管理器所提供的强大功能,按照需求来实现应用程序的设计。,用户可以启动Visual Foxpro,选择【文件】|【新建】命令,在打开的对话框中,选择“项目”单选按钮,然后单击“新建文件”按钮,接着在“创建”对话框中,输入项目文件名并确定项目路径(本例使用的路径为D:图书管理系统),然后单击“保存”按钮,即可启动项目管理器。,帮助菜单:显示在应用程序主菜单栏上的一个菜单。,dll、特定地区资源文件Vfp6rchs.,2)功能需求:功能分析的任务是了解用户对数据的处理方法和输出格式。,dbf 样式的帮助或者Windows样式的帮助。,在Visual FoxPro中,我们可以创建.,当然除了创建一个包含有用信息的帮助之外,还需要向应用程序用户提供访问帮助的途径。,用户表:读者编号、用户名、密码等。,数据库物理设计的任务就是具体确定表的结构,包括字段名、字段类型及宽度、需要的索引等。,借阅信息(读者编号、读者姓名、书号、借书日期、还书日期),用户可以启动Visual Foxpro,选择【文件】|【新建】命令,在打开的对话框中,选择“项目”单选按钮,然后单击“新建文件”按钮,接着在“创建”对话框中,输入项目文件名并确定项目路径(本例使用的路径为D:图书管理系统),然后单击“保存”按钮,即可启动项目管理器。,数据库设计是系统设计的一项基本工作,其效果的好坏,对后续设计、调试、使用、维护等工作关系极大,因此,一定要高度重视这一部分工作。,借阅信息(读者编号、读者姓名、书号、借书日期、还书日期),选择【工具】|【向导】|【全部】命令,打开对话框,选择“安装向导”项,然后单击“确定”按钮。,在弹出的安装向导对话框中,根据向导要求,运行以下7个步骤。,Windows样式的帮助在Visual FoxPro6.,10.1.4 数据库的物理设计,数据库物理设计的任务就是具体确定表的结构,包括字段名、字段类型及宽度、需要的索引等。,10.1.5 界面设计,1)创建启动表单,下面设计应用程序的封面,主要由一个表单来实现.,2)创建身份验证表单,3)创建主表单:,当用户输入用户名和密码通过验证正确以后,屏幕则会出现主表单。,10.1.6 主菜单设计,用户表(读者编号、用户名、密码),这些文件在Windows的System目录(或者Windows NT的System32目录)中都可以找到。,读者(读者编号、读者姓名、性别、出生日期、民簇、籍贯、联系 、照片),在数据录入和修改过程中应保持数据的参照完整性。,1)数据需求:通过调查,总结出该应用程序对数据的需求大致有如下这些:,app文件需要首先启动Visual Foxpro,然后从“程序”菜单中选择“运行”,选择要执行的应用程序;,在弹出的安装向导对话框中,根据向导要求,运行以下7个步骤。,在Visual FoxPro中,我们可以创建.,用户表:读者编号、用户名、密码等。,在项目管理器中创建一个项目后,应用程序就具备了一个开发框架,然后在这个框架中,再利用项目管理器所提供的强大功能,按照需求来实现应用程序的设计。,(2)根据对E-R图进行分析建立关系模型,1)借阅信息:包括读者编号、读者姓名、书号、借书日期、还书日期等。,dll、特定地区资源文件Vfp6rchs.,(4)打印输出:打印图书清单和图书借阅情况表等。,图书(书号、作者编号、书名、价格、数量、出版社),上下文相关帮助:当选定某个对象、控件或菜单选项并按F1键(或您指定的其他键)时显示的帮助。,借阅信息(读者编号、读者姓名、书号、借书日期、还书日期),app文件需要首先启动Visual Foxpro,然后从“程序”菜单中选择“运行”,选择要执行的应用程序;,10.1.7 表单设计,为了实现和完善“图书管理系统”应用程序的功能,下面通过表单的调用来实现某些特定的底层功能。,10.1.8 报表设计,在图书管理系统中,为了实现打印报表的功能,下面利用多个数据表来创建“图书清单”报表。,10.1.9 用项目管理器连编成应用程序,设置文件的“排除”与“包含”,2),设置主程序,3),连编项目,4),连编应用程序,5),连编其他选项,6)运行应用程序,当为项目建立了一个最终的应用程序文件之后,就可运行它了。,运行.app文件需要首先启动Visual Foxpro,然后从“程序”菜单中选择“运行”,选择要执行的应用程序;或者在“命令”窗口中,键入do。,生成的.exe应用程序文件既可以象上面一样在Visual Foxpro中运行,也可以在windows中双击.exe文件的图标运行。,10.2 应用程序的发布,所谓应用程序发布是指为所开发的应用程序制作一套应用程序安装盘,使之能够比较方便地安装到其它计算机上使用。,10.2.1 发布树,发布应用程序之前,需要将所有应用程序和支持文件复制到一个事先准备好的目录下面,这个目录就称之为“发布树”。也就是说,我们要将用户运行应用程序所需要的全部文件放在一个专用目录中,该目录最好是在Visual Foxpro目录外另建的。这些文件包括:,.exe可执行文件。,连编时未自动加入项目管理器中的文件。,设置为“排除”类型的文件。,支持库Vfp6r.dll、特定地区资源文件Vfp6rchs.dll(中文版)和Vfp6renu.dll(英文版)。这些文件在Windows的System目录(或者Windows NT的System32目录)中都可以找到。,10.2.2 应用程序发布和安装,Visual Foxpro中提供的安装向导能根据发布树中的文件创建安装盘,然后利用安装盘,就可以轻松地来安装并运行应用程序。选择【工具】|【向导】|【全部】命令,打开对话框,选择“安装向导”项,然后单击“确定”按钮。在弹出的安装向导对话框中,根据向导要求,运行以下7个步骤。,10.3 联机帮助,任何商品化的软件,都需要功能强大的帮助系统。帮助系统对于应用软件的用户来说是非常具有价值的信息来源,可以帮助用户很快了解和使用系统。,在Visual FoxPro中,我们可以创建.dbf 样式的帮助或者Windows样式的帮助。Windows样式的帮助在Visual FoxPro6.0中提供了两种方式:传统的WinHELP图形帮助和新版本特有的HTML帮助方式。当然除了创建一个包含有用信息的帮助之外,还需要向应用程序用户提供访问帮助的途径。现在一般有3种方法可以发布帮助:,帮助菜单:显示在应用程序主菜单栏上的一个菜单。,上下文相关帮助:当选定某个对象、控件或菜单选项并按F1键(或您指定的其他键)时显示的帮助。,“这是什么”帮助:当用户寻求关于特定对象或控件的帮助时出现的简单的弹出式帮助信息。,
展开阅读全文