资源描述
单击此处编辑母版标题样式,单击此处编辑母版文本样式,第二级,第三级,第四级,第五级,PPT,文档演模板,Office,PPT,10 十一月 2026,VoIP专题培训,培训提纲,VOIP基本原理,常见故障处理,VoIP基本原理,概述,VoIP,是 Voice over Internet Protocol的缩写,指的是将模拟的声音信号经过压缩与封包之后,以数据封包的形式在IP 网络的环境进行语音讯号的传输,通俗来说也就是互联网电话、网络电话或者简称IP电话的意思。,VoIP,应该还包括:,FoIP(Fax over IP),MoIP(Modem over IP),VoIP基本原理,VoIP系统组成,VoIP,系统由媒体网关(MG)、媒体网关控制器(MGC)、媒体服务器(MS)等部分组成。,媒体网关(MG)分为:AG(接入网关)、TG(中继网关)和 SG(信令网关)。,VoIP基本原理,应用背景,VoIP基本原理,工作原理,信令:H.248(Megaco)、SIP、MGCP、H.323,媒体:RTP(RTCP)、T.38,媒体,信令,信令,MG,Softwtich,MG,PSTN,TG(SG),信令,媒体,VoIP基本原理,媒体协议,1.采用UDP封装,2.语音:RTP(RTCP),3.语音编解码:G.711A/u、G.729、G.723.1,4.DTMF传输:RFC2833、RFC2198,5.传真:T.38、T.30,6.回声抑制:,G.165/G.168(32-128MS),7.,语音活动检测以及舒适噪音生成,VoIP基本原理,RTP包格式,0 1 2 3 8 16,31,V=2,p,x,cc,m,PT,顺序编号,时间戳,SSRC(同步信源标识符),CSRC,V:版本,RFC1889 定义为2,P:填充,若设置次位,包的实际数据内容比包本身小,X:扩展,若设置扩展,固定报头后是报头扩展,CC:CSRC 数值,标记多个CSRC数目,M:标记,可用来标记谈话的开始,PT:有效载荷,定义了有效载荷类型(G.711u/A,G.729,G.723,RFC2833),顺序编号:,用于分析丢包率,VoIP基本原理,RTP包实例,PT值:,0,-G.711U,8,-G.711A,18,-G.729,4,-G.723.1,VoIP基本原理,语音编码带宽,有效载荷格式,定义速率,打包速率,(ms),有效载荷大小(字节),所需带宽,(kbps),G.711A/u,64K,20,160,85.6,G.729,8K,20,20,29.6,G.723.1(5.3K),5.3K,30,20,19.8,G.723.1(6.3K),6.3K,30,24,20.8,注:IP包头大小为42字节,RTP包头为12字节,“所需带宽”包括IP和RTP包头大小,带宽计算:,(160+1242)*8*(1000/20)=85.6Kbps,VoIP基本原理,语音缓冲区动态调整,DSP,1.网络抖动、时延、丢包引起语音质量下降,2.通过DSP完成缓冲区动态调整,使语音更趋平滑,3.语音时延与语音清晰度平衡点,4.对收端来说,语音失真尽量消除,VoIP基本原理,语音丢包补偿技术,1.网络拥塞会引起丢包,2.如果不做丢包补偿,用户将听到,pops&Clicks,3.对语音而言,丢包补偿的方式是插值算法,4.对传真面言,所传的包中含有上一个包的信息(冗余技术),1,2,4,6,5,3,2,4,VoIP基本原理,静音激活技术(VAD),1.静音检测功能(VAD Voice Active Detect),2.舒适噪音生产功能(CNG),3.降低带宽,4.静音包的PT值:,G.711U/A -0 x0d,G.729和G.723.1与正常的语音包保持一致,VoIP基本原理,DTMF中继技术,IP Network,(RFC2833),10/100 BaseT,FXS,ZTE IAD,FXS,PBX,1,2,3,4,5,6,7,8,9,*,0,#,1,2,3,4,5,6,7,8,9,*,0,#,DTMF,DTMF,Message,ZTE IAD,VoIP基本原理,UDPTL传真包格式,VoIP常见故障处理,传真问题处理,智能公话处理,来电显示问题处理,MODEM应用问题处理,二次拨号问题处理,VoIP常见故障处理传真,(1)阶段A-呼叫建立,同一般的电话呼叫过程,主叫传真机拨通被叫传真机,可以手动也可以自动。,(2)阶段B-报文前过程,双方传真的标识和性能协商,包括能力标识、能力协商、非标准协商、训练过程等等。,(3)阶段C-报文传送,阶段C2为传真报文过程,阶段C1为对传输报文过程的控制,例如同步,差错校验等。,(4)阶段D-报文后过程,一页报文传输结束后的处理,包括报文结束、接收到报文的证实、多页传送、传真过程结束等。,(5)阶段E-呼叫释放,本次传真通信失败,释放传真通信线路。,每次传真通信均由这五个阶段组成,某一阶段不正常传真通信双方将放弃通信,按通信失败处理。,VoIP常见故障处理传真,主叫发送单音信号CNG表示要开始进入传真,被叫回CED标识终端。这两个信号是阶段A最后的两个信号;,接着被叫发送DIS标识被叫能力。只有被叫才发送DIS信号。此时进入阶段B;,主叫收到DIS信号后回DCS信号,表示响应;,主叫发送TCF,进行训练,TCF是1.5秒的0信号;,训练完毕,被叫发CFR信号,表示训练完毕,可以进行传送,此时阶段B完毕,进入阶段C传送阶段。图中略去传送过程;,传送一页后,主叫发送MPS信号,表示还有文件要进行传送,这时被叫回MCF,表示已经收到满意的报文,可以再发送其他文件;,主叫此时再进入训练状态,然后再传送一页内容;,多页传真完毕后,接入阶段D。这时主叫发送EOP信号,表示一页发送完毕,无后续报文传送,被叫这时回MCF,表示收到满意的报文;,主叫挂断,发送DCN信号,此时已经进入阶段E。,VoIP常见故障处理传真,T.30 与 T.38,IP Network,10/100 BaseT,ZTE IAD,ZTE IAD,10/100 BaseT,Fax,Fax,T.30,T.30,T.38,T.38,VoIP常见故障处理传真,跟T38有关的参数:,TCF训练模式:procedure1和procedure2,ECMenable,跟T30有关的参数:,G711冗余包,VoIP常见故障处理传真,传真切换方式:,SS全控方式:通过信令控制切换,ZTE自切换方式:通过RTCP-APP包来切换,VoIP常见故障处理传真,SS全控切换方式,1)SS下发检测传真信号的事件 E=654311430ctyp/dtone,2)被叫AG检测到V21 FlAG后上报给SS,OE=65431143020060603T15034900:ctyp/dtonedtt=V21flAG,3)SS下发SDP让被叫选择,v=0,c=IN IP4$,m=image$udptl t38,a=T38FaxRateManAGement:transferredTCF,a=T38FaxUdpEC:t38UDPRedundancy,a=T38MaxBitRate:14400,a=ptime:20,v=0,c=IN IP4$,m=audio$RTP/AVP 8,a=ptime:10,4)被叫AG选择VBD(T30)或者T38,v=0,c=IN IP4$,m=image$udptl t38,a=T38FaxRateManAGement:transferredTCF,a=T38FaxUdpEC:t38UDPRedundancy,a=T38MaxBitRate:14400,a=ptime:20,或,v=0,c=IN IP4$,m=audio$RTP/AVP 8,a=ptime:10,VoIP常见故障处理传真,传真问题处理步骤:,1.检查传真配置,包括T.30/T.38,T.38还要注意TCF训练模式,ECMdisable;,2.检查是否有丢包,用抓包分析工具;,3.分析信令,AG是否检测到了传真信号,没有的话看SS是否下发检测传真信号;传真被叫的话看是否有媒体通道切换信令;,4.看T30传真两边冗余个数是否一致;,5.看是否跟外线有关系;,6.看是否跟传真机类型有关系,传真机是否是高速传真机;,7.传真机error correction设置成OFF;,VoIP常见故障处理智能公话,智能公话原理,智能平台通过DTMF信号和智能话机进行通讯,控制计费和显示计费信息,国内智能平台主要有中兴和华为两种。各自终端不兼容。,VoIP常见故障处理智能公话,智能公话原理,智能公话和传统公话的区别?,传统公话:计费器普通话机 通过反极性信号,智能公话:智能话机 智能平台控制通话、计费和显示,智能公话是否需要配置反极性属性?,VoIP常见故障处理智能公话,VOIP软交换智能公话成败的关键DTMF是否成功传送;,相关参数:,DTMF relay模式:语音透传,nRed 2833模式,Red 2833模式,回声影响:修改线路增益,VoIP常见故障处理智能公话,智能公话问题常见故障现象,摘机拨号后无反映,被叫摘机后听忙音,挂机后计费信息不显示,VoIP常见故障处理智能公话,智能公话问题处理,1.智能平台和SS上数据配置(看信令,普通电话测试),2.DTMF relay 模式配置,3.修改线路增益,抑制回声,VoIP常见故障处理来电显示,来电显示问题,来电显示方式:DTMF方式和FSK方式,DTMF:每个数字由两个频率对应,FSK:1和0有两种频率载波表示,DTMF抗干扰强,FSK方式数据传输速率高,因此在规定时间内能传的字符数多,FSK方式支持ASC11字符集,DTMF方式只支持数字及少数字符,VoIP常见故障处理来电显示,来电显示格式(简单格式),消息类型(04H),消息长度(该长度不包括校验和),呼叫日期,呼叫时间,主叫号码(若终端交换机没有收到主叫号码,则用“O”OUTOFAREA表示;若不允许显示主叫号码,则用“P”PRIVATE表示);,6)校验和,SGandisp/dwaddb=041030353135313732363737373730303733AB,pattern=3,VoIP常见故障处理来电显示,来电显示格式(复合格式),消息类型(80H),消息长度,若干个参数消息(包含参数类型、参数长度、参数体),校验和,01H表示参数体为呼叫日期与时间,02H表示参数体为主叫号码,04H表示无主叫号码,07H表示参数体为主叫户主姓名,08H表示无主叫户主姓名,SGandisp/dwaddb=8016010830313037313334390204303237330704303237331f,pattern=2,VoIP常见故障处理来电显示,来电显示H248信令格式,!/1 10.6.160.1:2944 T=2636080481C=3269MF=USER00200600017MTSfsk/fsktype=1,SGal/ri,fsk/fskd=2009-07-30,t=11:36:24,c=13804554950,VoIP常见故障处理-来电显示,来电显示问题处理,1.软交换上是否配置有来显功能,信令检查,如果网关有区别振铃功能,可以听铃音来区别是否配置了来电显示,2.话机是否装了电池,3.是否有初始振铃,4.设备接地,5.ADSL线路干扰,分离器问题,VoIP常见故障处理-MODEM应用,窄带MODEM应用问题,窄带语音拨号上网、POS机业务、彩票机业务、MODEM对拨业务,VoIP常见故障处理-MODEM应用,窄带MODEM应用问题处理思路,1.是否丢包,2.SS上配置业务控制媒体(ZTE SS),3.Modem模式设置成全控MODEM,4.外线问题,5.MODEM兼容性问题,!/1 10.67.5.53:2944 T=348805776C=$A=USER00500600003,A=$MST=1OMO=RC,nt/jit=40,L,v=0,c=IN IP4$,m=audio$RTP/AVP 8 0,a=ptime:10,a=X-ChannelAttr:1,VoIP常见故障处理-二次拨号,二次拨号问题处理,二次拨号应用包括:,各种自动语音服务,200电话,二次拨号问题的关键DTMF relay模式,
展开阅读全文