资源描述
单击此处编辑母版标题样式,单击此处编辑母版文本样式,第二级,第三级,第四级,第五级,*,*,单元一,AutoCAD,的基本功能,【,单元描述,】,AutoCAD,是,Autodesk,公司开发的一款绘图软件,也是目前市场上使用率极高的辅助设计软件,他它广泛的用于建筑、机械、电子、服装、化工及室内装潢等工程设计领域。它可以更轻松的帮助用户实现数据设计、图形绘制等多项功能,从而极大地提高了设计人员的工作效率,已成为广大工程技术人员必备的工具。,AutoCAD,中文版有着特定的界面和操作方法。,作为全书的开篇,本章首先介绍,AutoCAD,的功能和优越性,以及基本工作界面和图形文件管理等内容。为后面章节的深入学校奠定坚实的基础。,第一章 运行与安装及界面概述,【,知识目标,】,1.,了解,AutoCAD,中文版基础平台,2.,建筑图形文件管理,3.,建筑工程绘图基础,第一章 运行与安装及界面概述,【,知识目标,】,1.,培养正确使用绘图界面,严格按规定要求绘制图形的能力。,2.,培养耐心细致一丝不苟的工作作风和动手绘图的能力。,1.1,软件运行环境:,软件环境:,操作系统:中文,windows7/windowsxp,软件环境:中文,autocad2007/2008/2010,版本。,1.2,软件安装方法:,1.3,AutoCAD,系统启动:,启动,AutoCAD,可以采用下面方式中的任何一种,:,(1),单击桌面上的“开始“按钮,选择“程序”中“,AutoCAD,”即可启动。,(2),双击桌面上的,AutoCAD,快捷图标。,1.4,绘图界面:,知识目标:,了解,AuotCAD,的绘图界面,熟悉,AutoCAD,的工作环境,掌握,AutoCAD,菜单栏的各项命令,第一章 运行与安装及界面概述,图,1-1,工作界面,(,绘图界面,),第一章 运行与安装及界面概述,图,1-2,标题栏,第一章 运行与安装及界面概述,1.4.1,标题栏,标题栏位于窗口的最顶端,用于显示当前正在运行的程序名及文件名等信息。,1.4.2,菜单栏,AutoCAD,的菜单栏继承了,Window,,的风格,.,单击主菜单即可弹出与其相应的子菜单,选择相应的选项即可执行或启动该命令。,AutoCAD,的菜单栏中包含主要的绘图命令及各种功能选项,如图,1-3,所示,图,1-3,菜单栏,(1),“文件”莱单,第一章 运行与安装及界面概述,图,1-4,“文件”菜单,图,1-5,“编辑”菜单,(2),“编辑”莱单,(3),“视图”菜单,第一章 运行与安装及界面概述,图,1-6,“视图”菜单,图,1-7,“插入”菜单,(,4,)“插入”菜单,图,1-8,“格式”菜单,(5),“格式”菜单,(6),“工具”菜单,第一章 运行与安装及界面概述,图,1-9,“文件”菜单,图,1-10,“绘图”菜单,(7),“绘图”莱单,图,1-11,“标注”菜单,(8),“标注”菜单,(9),“修改”菜单,第一章 运行与安装及界面概述,图,1-12,“修改”菜单,图,1-13,“窗口”菜单,(10),“窗口”菜单,图,1-14,“帮助”菜单,(11),“帮助”菜单,图,1-15,“工具”菜单,第一章 运行与安装及界面概述,1.4.3,工具栏,工具栏包括很多命令按钮,.,它们是应用程序调用命令的另一种方式。在默认状态,AutoCAD,窗口显示了“标准”、“对象特性”、“绘图”和“修改”等工具栏。,1.4.4,绘图区,绘图区是,AutoCAD,的工作区域,.,所有的绘图操作都要在这个区域中完成。在绘图区除了显示绘图结果外,.,还显示当前使用的坐标系类型,坐标原点、,X,轴,Y,轴及,Z,轴的方向等。在默认状态下,.,坐标系为世界坐标系,(WCS).,用户也可以根据设计需要更改坐标系。例如,.,在进行,1.4.5,命令行与文本窗口,图,1-16,“命令”菜单,图,1-17,“状态栏”菜单,第一章 运行与安装及界面概述,1.4.6,状态栏,状态栏位于,AutoCAD,工作界面最底部,用来显示当前的状态。,(1),【捕捉】按钮开启或关闭捕捉功能,.,图,1-18,“草图设置”对话框,第一章 运行与安装及界面概述,(2),【栅格】按钮,该按钮处于按下状态时,屏幕上将显示网格点。,(3),【正交】按钮,在正交模式下,系统以正交方式绘图,即所绘制的直线只能是水平或竖直的。,(4),【极轴】按钮,当极轴模式开启时,系统以极坐标的形式显示定位点。并随光标移动指示当前的极坐标。,(5),【对象捕捉】按钮,在对象捕捉模式下,系统将按设定的捕捉方式对图形元索中的特殊几何点,(,例如端点、中点、圆心和切点,),等进行捕捉。,(6),【对象追踪】按钮,单击此项将开启或关闭自动追踪功能。该功能可以对图形对象进行正交追踪或极轴追踪。,(7),【线宽】按钮,不启用该功能,按系统默认的宽度显示线条。启用该功能后,则图形中显示有宽度属性的线条。,(8),【模型】按钮或【图纸】按钮,单击该按钮,可以实现图纸空间和模型空间的切换。,第一章 运行与安装及界面概述,1.5,基本系统操作,知识目标:,了解,AutoCAD,的各项菜单命令,熟悉运行环境,掌握,AutoCAD,的基本系统操作,1),建立新图形文件,命令行,:NEW,工具栏,:,标准工具栏一新建,下拉菜单,:,文件一新建,功能,:,建立新的绘图文件,以便开始一个新绘图作业。,2),打开现有图形,命令行,:OPEN,工具栏,:,标准工具栏一打开,下拉菜单,:,文件一打开,功能,:,打开现有的,AutoCAD,图形文件。,第一章 运行与安装及界面概述,1.5,基本系统操作,3),保存文件,命令行,:QSAVE,工具栏,:,标准工具栏保存,下拉菜单,:,文件保存,功能,:,将现有的,AutoCAD,图形文件存盘。,4),换名存盘,命令行,:SAVE AS,下拉菜单,:,文件另存为,功能,:,将现有的,AutoCAD,图形文件以新的文件名字存盘。,5),将图形文件以当前文件名或指定文件名存盘,命令行,:SAVE,操作格式,:SAVE,命令只能在命令行中使用。,第一章 运行与安装及界面概述,1.5,基本系统操作,1.5.1,其他操作,1),图形窗口与文字窗口的切换,使用,AutoCAD,绘图时,有时需要切换到文本窗口,以便观看有关的文字信息。利用,F2,键可以实现上述切换。,2),退出,AutoCAD,当用户要退出,AutoCAD,时,切不可直接关机,应按下述方法之一进行,:,(1),执行下拉菜单项“文件一退出”选择下拉菜单项“文件一退出”。,(2),利用命令,QUIT,退出,AutoCAD,在命令行健入“,QUIT,。,(3),利用命令,END,退出,AutoCAD,在命令行键入“,END,。,1.5.2,绘图前的准备知识,(1),键盘,键盘的作用有以下几种,:,在命令行输入命令,输入命令后敲回车键或空格键,命令开始执行。,某些命令结束时需要敲回车键或空格键。按回车键或空格键表示确认。,键盘上输入数据。,(2),鼠标,鼠标的左键是拾取键,右键是确认键,并等同于回车键或空格键。另外,,AutoCAD,专用鼠标的中键为快捷键,按下中键拖动鼠标相当于实时平移。,第一章 运行与安装及界面概述,在建筑绘图中,无论是平面图,立面图还是剖面图,统称为建筑平面图。而任何二维的图形二维图形都是由点、直线、圆、圆弧和矩形等基本元素构成的,只有熟练掌握这些基本元素的绘制方法,才能绘制出各种复杂的图形对象。,本章主要介绍了十几个常用绘图命令,即绘制点和点样式设置、绘制直线、绘制圆、绘制圆弧、绘制多段线、绘制矩形。绘制正多边形、绘制椭圆和椭圆弧、绘制圆环,:,绘制样条曲线、绘制多线和多线样式设置、绘制云线,;,同时选用鼠标控制光标、对象捕捉、自动追踪等功能辅助绘图。,通过对本章的学习,读者将会对二维图形的基本绘制方法有一个全面的了解和认识,并能够使用常用的绘图命令来绘制出简单的二维图形。,重点与难点,1.,用,LINE,命令绘制矩形,2.,多段线的使用,3.,正多边形的绘制,2.2,绘图工具栏,知识目标:,了解绘图工具栏的作用,熟悉绘图栏各项命令的作用,掌握线、多段线、矩形、圆、圆弧命令画法,2.3,绘点命令,知识目标:,了解点样式的设置,熟悉点的形式,掌握点的绘制,命令行,:POINT,(,回车,),下拉菜单,:,绘图点,工具栏,:,绘图工具栏,命令:“,POINT,”命令后回车,,指定点,:(,使用鼠标或键盘输入绘制点,),第二章,简单的二维绘图,图,2-2,【绘图】工具栏,2.4,绘直线命令,知识目标:,了解直线命令的快捷键,(L),熟悉直线命令,掌握直线的绘制,命令行:,LINE(L),下拉菜单,:,绘图直线,工具栏:绘图工具,命令:“,LINE,”后回车,LINE,指定第一点,:,下一点,:,下一点,:,第二章,简单的二维绘图,2.5,绘多段线命令,知识目标:,了解多段线的作用,熟悉多段线的样式,掌握多段线的绘制,命令行:,PLINE,下拉菜单,:,绘图绘多段线,工具栏,:,绘图,功能,:,绘制二维多段线可以由等宽或不等宽的直线以及圆弧组成,如图,2-5,所示。,AutoCAD,把多段线看成是一个单独的对象,.,用户可以用多段线编辑命令对多段线进行各种修改操作。,第二章,简单的二维绘图,2.6,绘制圆,知识目标:,了解圆的的快捷键(,C,),熟悉圆的命令,掌握圆的绘制,(1),绘制圆的方法绘制圃的方法有三种,:,.,命令,:CIRCLE(,快捷键,C);,菜单:绘图圆,按钮:,第二章,简单的二维绘图,2.7,绘制圆弧,知识目标:,了解圆弧的快捷键(,A,),熟悉圆弧的简单绘制,掌握圆弧的多样绘制,(1),绘制圆弧的方法 绘制圆弧的方法有三种,:,.,命令,:ARC(,简写,:A),菜单:绘图 圆弧,按钮:,第二章,简单的二维绘图,(2),参数,三点,:,指定圆弧的起点、第二点、终点。,起点,:,指定圆弧的起始点。,第二点,:,指定圆弧上任意一点。,圆心,:,指定圆弧的圆心,.,端点,:,指定圆弧的终止点。,方向,:,指定和圆弧起点相切的方向。,长度,:,指定圆弧的弦长,.,正值绘制小于,180,的圆弧,负值绘制大于,180,的圆弧。,角度,:,指定圆弧包含的圆心角。顺时针为负,逆时针为正。,半径,:,指定圆弧的半径,.,按逆时针绘制,.,正值绘制小于,180,的圆弧,负值绘制大于,180,的圆弧。,第二章,简单的二维绘图,图,2-9,常见的圆弧绘制方法,三点,起点、圆心、端点,起点、端点、方向,起点、端点、角度,起点、圆心、长度,继续,起点、端点、半径,起点、圆心、角度,2.8,绘制矩形,知识目标:,了解矩形的快捷键(,REC,),熟悉矩形的多样绘制,掌握矩形的快速绘制,(1),绘制矩形的方法有三种,:,命令,;RECTANGLE(,简写,:REC.);,菜单:“绘图矩形”命令,按钮:,2.9,绘制正多边形,了解正多边形的快捷键(,POL,),熟悉正多边形的多样绘制,掌握正多边形的快速绘制,(1),绘制正多边形的方法有三种,:,.,命令,:POLYGON(,简写,:POI),菜单,:,“绘图”“多边形”。,按钮:,第二章,简单的二维绘图,2.10,绘制椭圆和椭圆弧,知识目标:,了解椭圆和椭圆弧的作用,熟悉椭圆和椭圆弧各项命令,掌握椭圆和椭圆弧的快速绘制,(,1,)绘制椭圆或椭圆弧的方法,绘制椭圆或椭圆弧的方法有三种,:,命令,:ELLIPSE(,简写,:EL),菜单:绘图椭圆,按钮:,第二章,简单的二维绘图,2.11,绘制圆环,知识目标:,了解圆环的快捷键(,DO,),熟悉圆环的绘制方法,掌握圆环的快速绘制,(1),圆环的方法有两种,:,命令:,DOUNT(,简写,DO),菜单:绘图”“圆环”。,(2),命令:,DONUT,指定圆环的内径,:,指定第二点,:,指定圆环的外径,:,指定圆环的中心点或,:,指定圆环的中心点或,:,(3),参数,内径,:,定义圆环的内圈直径。,外径,:,定义圆环的外圈直径。,中心点,:,指定圆环的圆心位置。,退出,:,结束圆环绘制,否则可以连续绘制同样的圆环。,第二章,简单的二维绘图,2.12,绘制多线和多线样式设置,知识目标:,了解多样线的快捷键,(ML),熟悉多样线的样式设置,掌握多样线的绘制,多线是一种多重平行线,.,在建筑图纸中常用来绘制道路、建筑墙线等对象。,2.12.1,绘制多线,绘制多线的方法绘制多线的方法有两种,:,命令,:MLINE(,简写,:ML).,菜单,:,绘图多线。,第二章,简单的二维绘图,2.12.2,多线样式设置,用缺省样式绘制出的多线是双线。我们还可以绘制三条或三条以上平行线组成的多线,,第二章,简单的二维绘图,图,2-14,“多线样式”对话框,“多线样式”对话框中的各项参数含义如下,:,(1),置为当前,显示当前多线样式,.,可以从列表中选择一个样式名使其成为当前样式。,(2),新建,输入新建的或,IR,命名的多线样式的名称。,(3),修改,为多线样式添加条件。,(4),加载,打开加载多线样式对话框。在此对话框中可以从指定的多线库,(.min),文件中加载多线样式。,(5),保存,将当前多线样式添加到指定的多线库,(mln),文件中。,(6),重命名,重命名当前的多线样式。输入样式名称,然后单击“重命名”按键,.,修改多线样式对话框中的各项按键含义如下:,添加:添加一条平行线,.,删除:删除一条平行线,.,偏移:为选中的平行线指定偏移量。,颜色:为选中的平行线指定颇色,.,线型:为选中的平行线指定某种线型,.,显示连接:控制每条多线线段顶点处连接的显示,.,如图,2-15,所示,.,封口:控制多线起点和端点的封口形式。,填充:控制多线的填充,单击“颜色”选择填充颜色。,第二章,简单的二维绘图,图,2-15,多线样式对话框,在使用,AutoCAD,进行建筑绘图时,使用基本绘图命令可以绘制图形,但想精确的绘制图形,还必须使用正交及对象捕捉来进行精确绘图。,AutoCAD,提供了捕捉对象特征点。如直线的中点、端点;圆的圆心、象限点,文字的插入点等,这些点对于特定的对象都是有唯一确定的点与之对应,我们在绘制和编辑图形时,往往需要在屏幕上指定一些点。板块的定点方法是通过光标直接拾取,.,但是此方法精度很低。用输入坐标的方法定点有很高的难度,.,且过程比较麻烦。所以,AutoCAD,提供了正交、捕捉、姗格等几种辅助绘图工具,.,可以精确而快速地控制光标的移动,有效提高绘图的速度,.,重点与难点,1.,正交模式,2.,精确定位和对象捕捉,3.,对象捕捉技巧,第三章,辅助绘图工具,图,3-1,正交模式使用实例,3.1,正交模式,知识目标:,了解正交的快捷键(,F8,),熟悉正交的功能,掌握正交作用,绘制水平和垂直直线时,.,打开正交模式,.,光标被约束在水平或垂直方向上移动。此模式可,在运行其他命令的过程中切换,.,打开正交模式有以下两种方法,:,1.,按钮,:,状态栏“正交”按钮,2.,快捷键,:F8.,第三章,辅助绘图工具,图,3-2,栅格阵网,3.2,栅格和捕捉,知识目标:,了解栅格的使用,熟悉捕捉的设置,掌握捕捉的使用环境,栅格是一个帮助定位的工具,在绘图区中显示类似于坐标纸一样的可见点阵,如图,3-2,所示。利用栅格设置可显示任何所需间距的点阵栅格。栅格仅在屏幕上显示,不会对图纸的输出产生任何影响。必要时可以将栅格隐藏起来以免妨碍细部观察。,第三章,辅助绘图工具,图,3-4,对象捕捉实例,3.3,对象捕捉,知识目标:,了解对象捕捉的作用,熟悉对象捕捉的设置,掌握对象捕捉的使用,在图形绘制过程中,常需要根据已有的对象来确定点坐标。对象捕捉可以帮助我们快速、准确地定位图形对象中的特征点,提高绘图的精度和工作效率。,第三章,辅助绘图工具,3.3.2,对象捕捉模式,一次性捕捉方式在每次进行对象捕捉前,需要先选择菜单或工具,.,比较麻烦。在进行连,续、大量的对象特征点捕捉时,.,常使用对象捕捉模式。对象捕捉模式可以先设置一些特征点名称,然后在绘图过程中连续地进行捕捉。,(1),对象捕捉模式设置方法,对象捕捉模式的设置方法有四种,:,命令,:OSNAP,菜单,:.,工具“草图设置”,;,按钮,:,“对象捕捉工具栏,快捷菜单,:,状态栏,设置,执行以上任一操作,将打开“草图设置”对话框,.,选择“对象捕捉”选项卡,如图,3-6,所示。,图,3-6,“对象捕捉”选项卡,第三章,辅助绘图工具,3.4,自动追踪,知识目标:,了解自动追踪的功能,熟悉自动追踪的方式,掌握自动追踪的使用,AutoCAD,具备自动追踪功能。“追踪”是指从图形中已有的点引出追踪线,将光标吸附在迫踪线上来定位所需的点。,自动追踪有网种方式一是极轴追踪。另一种是对象追踪,(,也称对象捕捉追踪,),。,3.4.1,极轴追踪,极轴追踪是在指定起始点后,.,命令提示指定另一点时,.,按预设的角度增量方向显示出追踪线,(,虚线,),。这时可将光标吸附在追踪线上,点取所需要的点。,极轴追踪与正交模式相似,.,但角度设定更为灵活,而且与对象捕捉结合使用时,还可捕捉,追踪线与图线的交点。,(1),设置极轴追踪的方法设置极轴追踪的方法有三种:,命令,:DSETTINGS:,菜单,:,“工具”“草图设置”,快捷菜单,:,状态栏“极轴按钮”“设置,。,执行以上任一操作,将打开“草图设置”对话框,.,选择“极轴追踪”选项卡,如图,3-7,所示。,图,3-7,“极轴追踪”选项卡,(2),参数,“启用极轴追踪”,:,打开或关闭极轴追踪,其快捷链为,F10,。,第三章,辅助绘图工具,3.4.2,对象追踪,对象追踪,(,又称对象捕捉追踪,),必须在对象捕捉、对象追踪模式同时打开时方可使用。它,可以在对象捕捉点发出各极轴方向的追踪线,这样就可以方便地获得追踪线上的点,此外,.,用它还可以抽捉到追踪线与图线,追踪线与追踪线的交点。,利用对象追踪功能,我们就可以在绘图过程中省去许多绘制辅助线的工作。,启用、关闭对象追踪可使快捷键为,F11.,在使用,AutoCAD,绘制建筑图形时,单纯地使用绘制工具只能创建一些简单的基础对象。对于复杂的建筑图形,往往不能一次完成,而是通过不断的修改来达到最终的效果,而,AutoCAD,提供复制、镜像、移动等命令来完成操作。,本章主要介绍图形编辑命令,包括图形的删除、复制、镜像、偏移、阵列、移动、旋转、缩放、修剪与延伸、打断、分解、倒角和圆角、多线段编辑和多线编辑等操作。,通过水章的学习,我们将了解操作对象的选择方法,.,掌握对象编辑命令的使用方法和技巧,.,使用夹点对对象进行简单的编辑,并能使用绘图工具和编辑命令来绘制园林、家装、工装等图纸中复杂的图形。,重点与难点,1.,镜像、移动、复制对象,2.,拉伸和修剪对象,3.,多线编辑对象,4.,图形的缩放,第四章,编辑图形,4.1,实体对象选择方式,知识目标:,了解应用参数应用方法选择对象,熟悉对象选择的方式,掌握基本体的快速选取,4.1.1,选择方式参数,在调用了,AutoCAD,命令后,,AutoCAD,会出现提示,可用以下任一种方式选择对象,:,(S):,点取通过使用拾取框或键入坐标,可以直接拾取对象。,(w):,窗口选择的对象是全部包括在矩形窗口中的对象。,(C):,窗交选择的对象是包括在矩形窗口中的对象,以及与矩形窗口边界相交叉的对象。,(WP):,圈围选择的对象是全部包括在多边形窗口中得对象,(CP):,圈交选择的对象是包括在多边形窗口中的对象,以及与多边形窗口边界交叉的对象。,(F):,栏选选择的对象是穿过一个多线段栅栏线。,(ALL):,全部选择图形中的所有对象。,(A):,将对象添加到选择集。,(X):,将对象清除出选择集。,(P):,如果存在前一个选择集,选择包含在前一个选择集中的所有对象。在选择对象的操作过程中,可以使用选择参数来选取对象。,第四章,编辑图形,对象的单个选择,用鼠标逐个地选择对象,如图,4-1,所示。,应用,C,参数用交叉窗口选择对象,如图,4-3,所示。,图,4-3,交叉窗口选择对象,图,4-2,开窗选择对象,第四章,编辑图形,应用,WP,参数用多边窗口选择对象,如图,4-4,(,a,)所示。,应用,C,参数应用,CP,参数用多边交叉窗口选择对象,如图,4-5,(,a,)所示。,多边交叉窗口选择对象是指窗口内和线上的对象。图,4-5,(,b,)中的图形均被选中。,用交叉窗口选择对象,如图,4-3,所示。,图,4-4,(,b,)中的,1,个椭圆和,1,个三角形被选中,图,4-4,(,a,)多边窗口选择对象,第四章,编辑图形,4.2,基本编辑命令,知识目标:,了解各项命令的快捷键,熟悉各项命令的操作,掌握删除、恢复命令的应用,4.2.1,删除命令,命令行,:ERASE(E),下拉菜单,:,修改删除,工具栏,:,修改删除对象,功能,:AutoCAD,将从图形中删除对象。,4.2.2,恢复命令,命令行,:OOPS,功能,:,用,OOPS,命令可以恢复最后一次用,ERASE,命令删除的对象。,4.2.3,取消命令,命令行,:UNDO,功能,:,用,UNDO,命令可以取消上一次执行的命令。,4.2.4,恢复取消命令,命令行,:REDO,功能,:,用,REDO,命令可以恢复被取消的上一次执行命令。,第四章,编辑图形,4.3,复制类命令,知识目标:,了解复制类命令的快捷键,熟悉复制类各项命令的操作,掌握复制、阵列、镜像、偏移命令的快速运用,4.3.1,复制命令,命令行,:COPY,下拉菜单,:,修改复制,工具栏,:,修改复制,(Y),功能,:,将指定的对象复制到指定的位置。,本例首先画一个圆,然后进行复制,复制后的图形如图,4-6,所示。,本例用,W,开窗选择多个对象,然后进行复制,复制后的图形如图,4-7,所示。,图,4-6,圆的复制,图,4-7,多个图形对象的复制,第四章,编辑图形,4.3.2,镜像复制命令,命令行,:MIRROR,下拉菜单,:,修改镜像复制,工具栏,:,修改镜像,(I),功能,:,将指定的对象按镜像方式复制到指定的位置。,应用,MIRROR,命令镜像复制多个图形对象。,本例操作后的图形如图,4-8,所示。,图,4-7,多个图形对象的复制,第四章,编辑图形,应用,MIRROR,命令镜像复制图,4-9(a),多个图形对象。,本例操作后的图形如图,4-9(b),所示。,图,4-9(a),图,4-9(b),镜像复制,第四章,编辑图形,4.3.3,阵列复制命令,命令行,:ARRAY,下拉菜单,:,修改阵列,工具栏,:,修改阵列,功能,:,按矩形或环形阵列的方式复制指定的对象,即把原对象按指定的格式进行多垂复制。,1),矩形阵列,若在“矩形阵列,(R),”选项处选择,系统切换为矩形方式阵列选项组,此组选项各项的意义如下,:,行数,(,一一一,)(4):,在文本框内输人矩形阵列的行数,(,包括被复制的对象,),。,列数(),(4):,在文本框内输人矩形阵列数,(,包括被复制的对象,),。,行偏移一一一,:,该选项要求用户输人矩形阵列的行间距。,列偏移(),:,该选项要求用户输人矩形阵列的列间距。,阵列角(,0,),:,该选项要求用户输人矩形阵列的旋转角度。,2),环形阵列,若在“环形阵列,(P),选项处选择,系统切换为环形方式阵列选项组,在此组选项各项的意义如下,:,中心点,:,该选项要求用户输人旋转中心点的坐标。,项目数,:,该选项要求用户输人阵列的个数,(,包括被复制的对象,),。,填充角度【,360,】:该选项要求用户输人环形阵列的圆心角。正值表示沿逆时针方向阵列,负值表示沿顺时针方向阵列,缺省为沿,360,的方向阵列。,第四章,编辑图形,图,4-11,环形阵列对话框,图,4-12,扇型阵列复制,图,4-10,(,b,)环形阵列对话框,图,4-10(c),环形阵列复制,第四章,编辑图形,4.3.4,偏移命令,命令行,:OFFSET,下拉莱单,:,修改偏移,工具栏,:,修改偏移,功能,:,对指定的线、弧及圆等对象作同心复制。对于直线而言,.,由于其圆心为无穷远,因此是平行移动。,图,4-15,(,a,)图像的偏移,图,4-15,(,b,)图像的偏移,图,4-15(C),第四章,编辑图形,4.4,修改类命令,知识目标:,了解修改命令的快捷键操作,熟悉修改命令基本操作,掌握修剪、拉伸、拉长、倒圆角命令的操作,4.4.1,修剪命令,命令行,:TRIM,下拉菜单,:,修改修剪,(TR),工具栏,:,修改修剪,功能,:,用修剪边修剪指定的对象,(,被剪边,),。,图,4-16,修剪前的图形,图,4-17,修剪图形,第四章,编辑图形,4.4.2,截断命令,命令行,:BREAK,下拉菜单,:,修改一打断,(BR),工具栏,:,修改打断,功能,:,将对象按指定的格式打断。,图形,4-18,图,4-19,图形对象的截断,第四章,编辑图形,4.4.3,延伸命令,命令行,:EXTEND,下拉菜单,:,修改延伸,(EX),工具栏,:,修改延伸,功能,:,延长指定的对象,使其到达图中选定的边界,(,又称为边界边,),上。,图,4-20,图形,图,4-21,图形对象的延伸,第四章,编辑图形,4.4.4,拉伸命令,命令行,:STRETCH,下拉菜单,:,修改拉伸,工具栏,:,修改拉伸,功能,:STRETCH,命令与,MOVE,命令类似,可以移动指定的一部分圆形。但用,STRETCH,命令移动图形时,.,这部分图形与其他图形的连接元素,如直线,(LINE),圆弧,(ARC),、等宽线,(TRACE),、多段线,(PLINE),等,将受到拉伸或压缩。,图,4-22(a),图,4-22(b),用,STRETCH,命令绘此图,第四章,编辑图形,4.4.5,拉长命令,使用“拉长”命令可以修改线段或圆弧的长度,.,拉长对象的方法拉长对象的方法,:,命令,:LENGTHEN(,简写,:LEN);,菜单:“修改”“拉长”,;,图,4-23(a),图,4-23(b),拉伸后的图形,第四章,编辑图形,4.4.6,倒圆角命令,在绘制图形时,经常会绘制倒角与圆角。在,AutoCAD,中提供了修“倒角”、“圆角”功能来完成这两种操作。,命令行,:FILLET,下拉菜单,:,修改圆角,(F),工具栏,:,修改圆角,功能,:,对指定的两个对象按指定的半径倒圆角。,图,4-24(a),图,4-24(b),矩形圆角,图,4-25,(,a,),图,4-25,(,b,)直线圆角,第四章,编辑图形,4.4.7,倒角命令,命令行,:CHAMFER,下拉菜单,:,修改倒角,(CHA),工具栏,:,修改倒角,功能,:,对指定的两个对象按指定的距离倒角。,4.4.8,分解命令,命令,:EXPLOOE(,简写,:X);,菜单,:,“修改”“分解”,;,按钮,:,执行分解命令后,命令行将提示要求选择分解的对象。选择要分解的图形后,该图形即分解为若干个单体。,图,4-27,图,4-28,图形对象的倒角,第四章,编辑图形,4.5,其他形式的命令,知识目标:,了解等分、多线编辑、复制剪切对象到剪切板的应用,掌握多段线编辑、测量工具的应用,熟悉移动、缩放、旋转命令的应用,4.5.1,移动命令,命令行,:MOVE,下拉菜单,:,修改移动,(M),工具栏,:,修改移动,功能,:,将指定的对象移到指定的位置。,操作格式,:,点取相应的菜单项、工具栏按钮或输人,MOVE,命令后回车。提示,:,图,4-30,图形的移动,第四章,编辑图形,4.5.2,缩放命令,命令行,:SCALE,下拉菜单,:,修改缩放,(SC),工具栏,:,修改缩放,功能,:,将对象按指定的比例因子相对于指定的基点放大或缩小。,操作格式,:,点取相应的菜单项、工具栏按钮或输人,SCALE,命令后回车。,图形,(4-31),图,4-32,图形的缩放,第四章,编辑图形,4.5.3,旋转命令,命令行,:ROTATE,下拉菜单,:,修改旋转,(RO),工具栏,:,修改旋转,功能,:,将所选对象围绕指定点,(,称为旋转基点,),旋转指定的角度。,操作格式,:,点取相应的菜单项、工具栏按钮或输人,ROTATE,命令后回车。,图,4-35,图,4-36,图形的旋转,第四章,编辑图形,4.5.4,多段线编辑命令,命令行,:PEDIT,工具栏,:,修改工具栏多段线,下拉菜单,:,修改一对象多段线,(P),功能,:,编辑和修改多段线。,操作格式,:,单击相应的菜单项、按钮或输入,PEDIT,命令后回车。,图,4-37,图,4-38,多用线的编辑,第四章,编辑图形,4.5.5,测量命令,命令行,:MEASURE,功能,:,测量图形对象的等距分数。,操作格式,:,输人,MEASURE,命令后回车。,4.5.6,等分命令,命令行,:DIVIDE,功能,:,把对象等分为,N,等份。,操作格式,:,输人,DIVIDE,命令后回车。,图,4-33,(,a,),图,4-33,(,b,)等分对象,第四章,编辑图形,4.5.7,复制对象到剪贴板,命令行,:COPYCLIP,下拉菜单,:,编辑复制,(C),热键,:Ctrl+C,功能,:,将指定的对象复制到剪贴板上。,操作格式,:,点取下拉菜单项“编辑复制”,或按下热键,Ctrl+C.,或输人,COPYCLIP,命令后回车。,4.5.8,剪切对象到剪贴板,命令行,:CUTCLIP,下拉菜单,:,编辑、剪切,(T),热键,:Ctrl+X,功能,:,将指定的对象放到剪贴板,.,上。,操作格式,:,点取下拉菜单项“编辑一剪切”,或按下热键,Ctrl+X,,或输人,CUTCLIP,后回车。,第四章,编辑图形,4.5.9,粘贴对象,命令行,:PASTECLIP,下拉菜单,:,编辑粘贴,热键,:Ctrl+V,功能,:,将剪贴板上的对象按指定比例粘贴到指定位置。,操作格式,:,点取下拉菜单项“编辑一粘贴”,或按下热键,Ctrl+V,,或输入,PASTECLIP,命令后回车。,图(,4-34,),图,4-35,复制、粘贴对象,第四章,编辑图形,4.5.10,多线编辑,多线绘制完成后,.,其形状往往不能完全满足需要。但多线是一个整体,用普通编辑命令是不能对它进行修改的,这就需要使用专门的多线编辑命令。“多线”命令可以控制多线间的相交形式,增加、删除多线的顶点,控制多线的打断或结合。,(1),多线编辑的方法多线编辑的方法有三种,:,命令,:MLEDIT;,菜单,:,“修改”“对象”“多线”,;,(2),命令与提示执行多线命令后弹出“多线编辑工具”对话框,.,如图,4.36,所示。,图,4.36,多线编辑工具,第四章,编辑图形,文字是建筑工程图中不可缺少的一部分,如标题栏的建立、技术要求的说明和注释等。它可以对图形中不便于表达的内容加以说明,使图形的含义更加清晰,从而使设计、修改和施工人员对图形的要求一目了然。,AutoCAD,提供了多种创建文字的方法,.,对简短的文字输人使用单行文字,;,对带有内部格式的较长的文字输人使用多行文字。文字输人时都使用当前文字样式控制其外观,但也可用其他方法来修改文字外观。,本章主要介绍单行文字命令,多行文字命令,建立和管理文字样式等内容。这两个命令主要用来在标题栏、会签栏和门窗列表等位置输入汉字、字母和数字等符号,标注单线图形的尺寸等。,重点与难点,1.,创建建筑标准文字样板,2.,单行文字,3.,多行文字,第五章 文字标注,5.1,文字标注的一般要求,知识目标:,了解文字标注的作用,熟悉文字标注的位置,掌握文字标注的高度应用,(1),字体要求标注文字的字体要求清晰易识,宜选用长仿宋体,字体种类应在够用的基础上尽量减少,.,并保持统一。,(2),分布要求文字方向通常平行于图纸底边或右侧边缘,并且尽可能不与图形内容重叠。文字应互相对齐,增强可读性,文字图层应与图形分开。,(3),字高与比例图纸的文字高度应从下列系列选取,(2-5.3.5,5,7,10.14,20 mm),,考,虑到打印出图时的比例因子,在模型空间绘制文字时应把希望得到的字高除以出图比例来定制字高,.,例如,:,在比例为,1,:,200,的图中,欲得到,8 mm,的字高,.,绘制时的字高应为,8,(1:200)=1 600,。,第五章 文字标注,5.2,文字样式的设置,知识目标:,了解文字样式的设置的快捷键(,ST,),熟悉文字样式设置对话框的个性命令,掌握基本的文字设置要求,文字样式是指控制文字外观的一系列格式特征,用于设置文字的字体、字高、角度、方向和其他特性。,AutoCAD,图形中的文字都有与它关联的文字样式,当关联的文字样式因修改而发生变化时,图形中所有应用了此样式的文字外观均会自动修改。我们可以在一个图形文件中设置,-,个或多个文字样式。,(1),文字样式的设置方法文字样式设置的方法有两种,:,命令,:STYLE(,简写,:ST);,菜单,:,“格式”“文字样式”。,执行该命令后,系统弹出如图,5.1,所示的“文字样式”对话框。在该对话框中,可以新建或修改文字样式。,(2),主要参数,应用按钮,:,将设置的样式应用到图形中。单击该按钮后,取消按钮变成关闭按钮。,图,5.1,文字样式对话框,第五章 文字标注,取消按钮,:,在应用之前可通过该按钮放弃前而的设定。在应用之后,该按钮变成,关闭按钮。,关闭按钮,:,关闭该样式设定对话框,.,最后选定的样式成为当前文字注写样式。,样式名区,:,(a),“样式名”列表框,:,显示当前文字样式。单击下拉列表框可以查看所有已建立的样式名,选取一种样式后,对话框的其他项目显示该样式相应的设置。列表中“,Standard,”样式为缺省的文字样式,该文字样式不可以删除。,(b),新建按钮,:,用于新建文字样式,.,文字样式名可以由用户指定,但应具有一定的意义,,这样使用时不至于混淆。新建的样式使用当前的样式设置。,(c),重命名,:,重新命名当前文字样式。,Standard,样式不可以重命名,.,(d),删除按钮,:,删除当前的文字样式,.,在图形中已使用的文字样式和二,Standard,,样式不可以删除。,字体区,:,用于设置文字样式使用的字体和字高等特性。,(a),“字体名”列表框,:,显示当前文字样式所用的字体名称,.,我们可以在下拉列表中选择,某种字体作为当前文字样式所川的字体,.,此项宜设为仿宋。,(b),“高度”,:,根据输入的值设置文字高度。此项宜设为,0,。如果输人,0,,每次用该样式输入文字时,.AutoCAD,都提示输人文字高度。如果输人值大午,0.,则在使用该文字样式输人文字时统一使用该高度,不再提示输入文字高度。,(c),使,A,大字体”复选框,:,大字体是指,AutoCAD,专用的非西文线形字体,如中文、日文等。只有选用英文,SHX,字体后,才可以打开该复选框,这时可以为该样式指定中文,SHX,字体。,(d),“大字体”列表框,:,选择,.,使用大字体”复选框后,该列表框有效。常用的中文大字体有,gbcbig.Shx,。,效果区,:,(a),“颠倒”,:,控制文字的上下颠倒效果。,(b),“反向”,:,控制文字的左右反向效果。,(C),“垂直”,:,控制,SHX,字体垂直书写。,(d),“宽度比例”,:,设定文字的宽高比。园林制图中,此项宜设为,0.7,。,(e),“倾斜角度”,;,设定文字垂直倾斜角度。园林制图中,.,文字如需写成斜体字,此项宜设为,15,。,预览区,:,(a),“预览框”,:,直观显示文字样式的预览效果。,(b),“文本框”,:,可以输人想预览的文字,.,(c),“预览”按钮,;,单击该按钮将在预览框中显示文本框中输人的文字。,第五章 文字标注,5.3,文字的输入,知识目标:,了解文字输入的快捷键,熟悉单行文字的输入,掌握多行文字的操作,5.3.1,单行文字的输入,在,AutoCAD,中,,TEXT,与,DTEXT,命令功能相同,都可以输入单行文本。,(1),单行文字输入的方法单行文字输入的方法有三种,:,命令,:DTEXT,(简写,:DT),,,TEXT,菜单,:,“绘图”
展开阅读全文