收藏 分销(赏)

Access 2003 建立报表.ppt

上传人:xrp****65 文档编号:13621540 上传时间:2026-04-03 格式:PPT 页数:49 大小:2.06MB 下载积分:10 金币
下载 相关
Access 2003 建立报表.ppt_第1页
第1页 / 共49页
Access 2003 建立报表.ppt_第2页
第2页 / 共49页


点击查看更多>>
资源描述
,单击此处编辑母版标题样式,单击此处编辑母版文本样式,第二层,第三层,第四层,第五层,*,第,6,章,建立报表,数据库中的表、查询和窗体都有打印的功能,通过它们可以打印比较简单的信息,要打印数据库中的数据,最好的方式是使用报表。报表是,Access,中专门用来统计、汇总并且整理打印数据的一种工具。要打印大量的数据或者对打印的格式要求比较高,则必须使用报表的形式。用户可以利用报表,有选择地将数据输出,从中检索有用信息。,Access 2003,报表的功能非常强大,也极易掌握并制作出精致、美观的专业性报表。,本章要点,6.1,创 建 报 表,6.2,编辑和打印报表,习题,6,6.1,创 建 报 表,创建报表与创建窗体的操作有很多类似的地方,用户可以采取多种方法来创建报表。,6.1.1,报表的基本概念,1,报表与窗体,报表中的大部分内容是从表查询或,SQL,语句中获得的,它们都是报表的数据来源。创建和设计报表对象与创建和设计窗体对象有许多共同之处,两者之间的所有控件几乎是可以共用的。它们之间的不同之处在于,报表不能用来输入数据,而在窗体中输入数据;报表只有“设计”视图和“打印预览”两种视图。,2,报表的组成,下面以“罗斯文”数据库为例介绍报表的基本概念。,打开“罗斯文”数据库,在“对象”列表中单击“报表”对象,如图,6-1-1,所示,双击“各类产品”报表,可以打开它的“打印预览”视图如图,6-1-2,所示。,6.1,创 建 报 表,图,6-1-1,“罗斯文”数据库的报表对象列表,图,6-1-2,“各类产品”报表的“打印预览”视图,6.1,创 建 报 表,单击工具栏上的“视图”按钮,可以切换到设计视图,如图,6-1-3,所示。,由,6-1-3,中可以看到,报表在设计视图中由报表页眉、页面页眉、主体、页面页脚和报表页脚五个部分组成。,图,6-1-3,“各类产品”报表的设计视图,6.1,创 建 报 表,(,1,)报表页眉只出现在报表的开头,并且只能在报表开头出现一次。报表页眉用来记录关于此报表的一些主题性信息。,(,2,)页面页眉只出现在报表中的每一页的顶部,用来显示列标题等信息。,(,3,)主体包含报表的主要数据,用来显示报表的基础表或查询的每一条记录的详细信息。,(,4,)页面页脚出现在报表中的每一页的底部,可以用来显示页码等信息。,(,5,)报表页脚只在报表的结尾处出现,用来显示报表总计等信息。,6.1.2,用向导创建报表,报表向导为用户提供了报表的基本布局,根据用户的不同需要可以进一步对报表进行修改。利用报表向导可以使报表创建变得更容易。在,Access 2003,中使用向导创建报表的具体操作步骤如下。,(,1,)打开数据库窗口中,单击“报表”对象,在“报表”对象窗口中,双击“使用向导创建报表”选项,调出“报表向导”对话框之一,如图,6-1-4,所示。,(,2,)单击“表,/,查询”下拉列表框右侧的向下箭头调出其下拉列表,从中选择创建窗体所需使用的表和窗体。,(,3,)在“可用字段”列表框中选择字段,单击按钮,将其添加到右半部分的“选定的字段”列表中,如图,6-1-4,所示。,6.1,创 建 报 表,(,4,)单击“下一步”按钮,调出“报表向导”对话框之二,如图,6-1-5,所示,选定添加分组级别以及分组的依据。分组是为了使生成报表的层次更加清晰。,(,5,)在图,6-1-5,中,单击“分组选项”按钮,调出“分组间隔”对话框,如图,6-1-6,所示,在这里可以为组级字段选定分组间隔。单击“确定”按钮,返回图,6-1-5,报表向导的分组中。,(,6,)单击“下一步”按钮,调出“报表向导”对话框之三,如图,6-1-7,所示。在“报表向导”对话框窗口中,选择排序次序,可以选择一个或几个字段作为排序和汇总的依据,排序可以选择升序或降序。,6.1,创 建 报 表,图,6-1-4 “,报表向导”对话框之一 图,6-1-5 “,报表向导”对话框之二,6.1,创 建 报 表,图,6-1-6 “,分组间隔”对话框 图,6-1-7 “,报表向导”对话框之三,6.1,创 建 报 表,(,7,)单击“下一步”按钮,调出“报表向导”对话框之四,如图,6-1-8,所示。在“报表向导”对话框报表布局方式窗口中,可以确定布局和方向。,(,8,)单击“下一步”按钮,调出“报表向导”对话框之五,如图,6-1-9,所示。在这个对话框中确定报表所用样式,本例中选择“组织”样式。,图,6-1-8 “,报表向导”对话框之四 图,6-1-9 “,报表向导”对话框之五,6.1,创 建 报 表,(,9,)单击“下一步”按钮,调出“报表向导”对话框之六,如图,6-1-10,所示,在这个对话框中为报表命名。,(,10,)单击“完成”按钮就可以成功创建报表,所创建的报表如图,6-1-11,所示。,图,6-1-10“,报表向导”对话框之六 图,6-1-11,用“报表向导”创建的报表,6.1,创 建 报 表,6.1.3,使用设计视图创建报表,使用报表向导可以简单、快速地创建报表,但创建的报表格式比较单一,有一定的局限性。为了创建具有独特风格、美观实用的报表,要使用设计视图来设计报表。,1,报表中控件的种类,利用设计视图创建报表主要是向报表中添加控件。报表控件通常可分为以下,3,种。,(,1,)非结合控件:与数据表中的数据无关的控件。,(,2,)结合控件:表或查询中的数据字段。,(,3,)计算控件:报表中用于进行计算的控件,例如总计、小计等。,2,用设计视图创建报表的方法,在,Access 2003,中用设计视图创建报表的具体操作步骤如下。,(,1,)打开数据库窗口,如图,6-1-12,所示。双击“报表”“在设计视图中创建报表”选项,调出报表的设计视图,如图,6-1-13,所示。,6.1,创 建 报 表,由图,6-1-13,可以看出,在设计视图窗口中没有报表页眉,/,页脚两个工作区,而只有页面页眉、主体和页面页脚。,图,6-1-12,选择“在设计视图中创建的报表”选项 图,6-1-13,设计视图窗口,6.1,创 建 报 表,(,2,)在设计视图窗口中用鼠标右键单击这个窗口,调出快捷菜单,如图,6-1-14,所示。,(,3,)在弹出的快捷菜单中单击“报表页眉,/,页脚”菜单命令,出现如图,6-1-15,所示的报表的页眉和页脚两部分内容。,图,6-1-14,在设计视图窗口中调出快捷菜单 图,6-1-15,出现页眉和页脚,6.1,创 建 报 表,(,4,)下面可以根据需要为报表添加一些控件,在“报表页眉”和“页面页眉”中利用工具箱中的“标签”按钮建立标签,并在标签中输入文字,在“主体”中用鼠标从字段列表框中拖入。结果如图,6-1-16,所示。,(,5,)单击工具栏上的“打印预览”按钮,可得到如图,6-1-17,所示的报表。,图,6-1-16,在报表中添加控件 图,6-1-17,完成的报表,6.1,创 建 报 表,6.1.4,自动创建报表,如果对格式要求不高,只需要看到报表中的数据,则可以快速创建一个简单的报表。使用,Access,自动创建报表的步骤如下。,(,1,)打开数据库窗口,选择“报表”对象。,(,2,)在数据库窗口中,单击工具栏上的“新建”按钮,调出“新建报表”对话框,如图,6-1-18,所示。,(,3,)选择“自动创建报表:纵栏式”选项,在下面的下拉列表框中选择数据的来源表。单击“确定”按钮,即可完成报表的创建工作,如图,6-1-19,所示。,6.1,创 建 报 表,图,6-1-18 “,新建报表”对话框 图,6-1-19,自动创建报表,6.1,创 建 报 表,6.1.5,使用标签向导创建报表,标签实际上是一种多列报表,常常把一条记录的各个字段分行排列,因此制作标签一般都是使用多列的方法。具体操作步骤如下。,(,1,)在数据库窗口中选择报表,单击工具栏上的“新建”按钮,调出“新建报表”对话框,选择“标签向导”选项,在下面的数据来源下拉列表框中选择“学生编号表”,如图,6-1-20,所示。,(,2,)单击“确定”按钮,调出“标签向导”对话框之一,如图,6-1-21,所示,从中选择标签的型号、尺寸和生产厂商。图,6-1-21,中选择了“,Avery”,厂商和“,C6101”,型号的标签。,6.1,创 建 报 表,图,6-1-20,选择“标签向导”图,6-1-21,“标签向导”对话框之一,6.1,创 建 报 表,(,3,)单击“下一步”按钮,调出“标签向导”对话框之二,如图,6-1-22,所示。在该对话框中,可对文本外观的字体、字号、粗细及颜色进行设置。,(,4,)单击“下一步”按钮,调出“标签向导”对话框之三,如图,6-1-23,所示。在“标签向导”对话框中,确定标签的显示内容。,(,5,)单击“下一步”按钮,调出“标签向导”对话框之四,如图,6-1-24,所示。在“标签向导”对话框中,可以选择一个或多个字段对标签进行排序。,(,6,)单击“下一步”按钮,调出“标签向导”对话框之五,如图,6-1-25,所示。在“标签向导”对话框中,输入报表的名称,同时选择“查看标签的打印预览”单选钮。,6.1,创 建 报 表,图,6-1-22“,标签向导”对话框之二 图,6-1-23,“标签向导”对话框之三,6.1,创 建 报 表,图,6-1-24 “,标签向导”对话框之四 图,6-1-25,“标签向导”对话框之五,6.1,创 建 报 表,(,7,)单击“完成”按钮,结果如图,6-1-26,所示。,图,6-1-26,用“标签向导”创建的报表,6.1,创 建 报 表,6.1.6,创建有图表的报表,Access,中的图表报表有多种样式,包括线条图、饼图、面积图等,还有三维图形。图表可以是所有数据的,也可以是选定的当前数据的。用户可以通过图表向导创建满意的图表。利用向导创建图表的方法如下。,(,1,)打开数据库窗口,选择“报表”对象。,(,2,)在数据库窗口中,单击工具栏上的“新建”按钮,弹出如图,6-1-27,所示的“新建报表”对话框。选择“图表向导”选项,并在下面下拉列表框中选择数据源。,(,3,)单击“确定”按钮后,调出“图表向导”对话框之一,如图,6-1-28,所示,在“可用字段”列表中选择字段,单击按钮,将其添加到“用于图表的字段”列表中。,6.1,创 建 报 表,图,6-1-27,选择“图表向导”图,6-1-28,“图表向导”对话框之一,6.1,创 建 报 表,添加字段时可以从不同的表中选择图表中所需的字段。,(,4,)单击“下一步”按钮,调出“图表向导”对话框之二,如图,6-1-29,所示。在对话框的左半部选择图形样式,在对话框的右半部有图形样式的说明。如图,6-1-29,所示选择三维柱形图。,(,5,)单击“下一步”按钮,调出“图表向导”对话框之三,如图,6-1-30,所示。选择数据在图表中的布局方式,对所选的两门课程的分数进行求和。,图,6-1-29 “,图表向导”对话框之二 图,6-1-30,“图表向导”对话框之三,6.1,创 建 报 表,(,6,)单击“下一步”按钮,调出“图表向导”对话框之四,如图,6-1-31,所示。在文本框中输入图表的标题,单击“完成”按钮,创建的图表如图,6-1-32,所示。,图,6-1-31 “,图表向导”对话框之四 图,6-1-32,创建的图表,6.2,编辑和打印报表,数据库中记录的排序和分组是一项很重要的工作,而这正是报表的主要功能之一。在打印报表时,一般还要对某个字段按指定的规则进行统计,报表设计完成后就可以打印了。在打印之前还要进行报表的相关设置,包括边距、打印机和报表行列等。设置完成后,可对报表进行预览,对设置满意之后,再进行打印。,6.2.1,排序和分组,1,记录的排序,在报表中用户根据实际需要按指定的字段或表达式对记录进行排序,打印报表时就会以指定的顺序进行打印。对报表的记录进行排序的操作步骤如下。,(,1,)在数据库窗口中单击“报表”对象,然后,选中需要的报表打开它的设计视图。图,6-2-1,“排序与分组”对话框,(,2,)单击工具栏上的“排序与分组”按钮,调出“排序与分组”对话框,如图,6-2-1,所示。,6.2,编辑和打印报表,图,6-2-1,“排序与分组”对话框,6.2,编辑和打印报表,(,3,)单击“字段,/,表达式”中的“类别名称”字段,单击其右侧的向下箭头,出现下拉列表框,从中选择用于对记录进行排序的字段名称。,(,4,)单击同一行中“排序次序”,单击其右侧的向下箭头符号,出现下拉列表框,从中选择用于对记录进行排序是“升序”还是“降序”。,(,5,)重复上两步操作,直到设置完所有的字段的排序。,在,Access 2003,中最多可以对,10,个字段进行排序,执行时先执行第一个字段的排序,然后再执行第二个字段的排序。排序时升序的次序是从,A,到,Z,或从,0,到,9,。,2,记录的分组,在,Access 2003,的报表中,可以对记录按指定的规则进行分组,分组后的每个组将显示该组的概要和汇总信息,在报表中对记录进行分组的具体操作步骤如下。,(,1,)打开要分组的报表的设计视图。,(,2,)单击工具栏上的“排序与分组”按钮,调出“排序与分组”对话框,如图,6-2-1,所示。,(,3,)单击“字段,/,表达式”中的“类别名称”字段,单击其右侧的向下箭头符号,出现下拉列表框,从中选择用于分组的字段名称。,6.2,编辑和打印报表,(,4,)单击“组页眉”右侧的向下箭头符号,从下拉列表框选择“是”选项,将“组页眉”的属性设置为“是”。,(,5,)用第(,4,)步的方法将“组页脚”的属性也设置为“是”。,注意:只有“组页眉”和“组页脚”的属性设置为“是”时,才可以创建分组。,(,6,)在“分组形式”下拉列表框中有“每一个值”和“前缀字符”两个选项,在“组间距”文本框中输入用于组的字符间隔和数目,在“保持同页”下拉列表框中有“不”、“整个组”和“与第一条详细记录”,3,个选项,根据需要进行设置以后关闭对话框。,单击工具栏上的“打印预览”按钮,可以查看分组的结果。图,6-2-2,所示为没有分组的报表,图,6-2-3,所示为设置分组后的报表,其分组的选项设置是:在“分组形式”下拉列表框中选择“每一个值”,在“组间距”文本框中输入“,1”,,在“保持同页”下拉列表框中选择“与第一条详细记录”。,6.2,编辑和打印报表,图,6-2-2,没有分组的报表 图,6-2-3,有分组的报表,6.2,编辑和打印报表,3,插入新的分组或排序,在已经设置了分组的报表中,如果需要插入新的分组或排序字段,可以按下面的步骤操作。,(,1,)打开报表的设计视图。,(,2,)单击工具栏上的“排序与分组”按钮,调出“排序与分组”对话框,如图,6-2-1,所示。,(,3,)单击空白行中的“字段,/,表达式”单元格,单击出现的向下箭头符号可以调出它的下拉列表框,从中选择要排序的字段或键入一个新的表达式。在“排序次序”下拉列表框选择“升序”还是“降序”。,(,4,)如果要改变排序的次序,单击要改变次序的字段的行选定器,用鼠标拖曳到新的位置。,设置完成后关闭“排序与分组”对话框。,4,删除排序或分组的字段或表达式,如果要取消报表中的某项排序或分组,可以按下面的步骤操作。,(,1,)打开报表的设计视图。,(,2,)单击工具栏上的“排序与分组”按钮,调出“排序与分组”对话框,如图,6-2-1,所示。,6.2,编辑和打印报表,(,3,)单击要删除的字段或表达式的行选定器,按,Delete,键,弹出提示对话框,如图,6-2-4,所示。,图,6-2-4,要求确认删除分组和排序,6.2,编辑和打印报表,(,4,)单击“是”按钮确定。,6.2.2,在报表中计算,在报表中有时要对某个指定的字段进行统计汇总,,Access,中提供了两种实现这个目的的方法,一种是在相应的表中加入字段,另一种是在报表输出打印时进行统计汇总。其中第二种方法得到广泛应用。,1,在报表中添加计算控件,(,1,)打开报表的设计视图。,(,2,)单击工具箱中要作为计算控件的按钮,单击设计视图中要旋转控件的位置。,(,3,)如果计算控件是文本框,直接输入以“”开始的表达式。图,6-2-5,在“控件来源”文本框中输入表达式,(,4,)如果计算控件不是文本框,则应该打开该控件的“属性”对话框,如图,6-2-5,所示,单击“数据”选项卡,在“控件来源”文本框中输入表达式。,(,5,)修改新控件的标签名称,将报表保存。,6.2,编辑和打印报表,图,6-2-5,在“控件来源”文本框中输入表达式,6.2,编辑和打印报表,2,在报表中计算记录的总计或平均值,在报表中计算记录的总计或平均值的具体操作步骤如下。,(,1,)打开报表的设计视图。,(,2,)如果要计算一组记录的总计或平均值,则可以将文本框添加到组页眉或组页脚中,如果要计算报表所有字段的总计或平均值,则可以将文本框添加到报表页眉或页脚中。,(,3,)打开该文本框的“属性”对话框,如图,6-2-5,所示,单击“数据”选项卡,在“控件来源”文本框中输入,Sum,函数计算总计值,如果要计算平均值,则要输入,Avg,函数。,3,用“表达式生成器”输入函数,在输入表达式时,如果对函数很熟悉,可以在文本框中直接输入函数,如果不是很熟悉则可以用“表达式生成器”来输入,具体操作步骤如下。,(,1,)按照上面所介绍的方法确定输入函数的位置。,(,2,)单击工具栏上的“生成器”按钮,调出“选择生成器”对话框,如图,6-2-6,所示。,(,3,)选择“表达式生成器”选项,单击“确定”按钮,调出“表达式生成器”对话框,如图,6-2-7,所示。,6.2,编辑和打印报表,图,6-2-6,“选择生成器”对话框 图,6-2-7,“表达式生成器”对话框,6.2,编辑和打印报表,(,4,)在“表达式生成器”对话框左侧的对象列表框中双击“函数”文件夹,单击其中的“内置函数”,这时在中间的列表框中列出了所有的类别,在右侧的值列表框中列出了所有函数。,(,5,)选中要输入的函数双击或单击“粘贴”按钮。,6.2.3,在报表中创建子报表,子报表是插入到其他报表中的报表。在合并报表时,两个报表中的一个必须是主报表。,主报表可以包括任意数目的子报表,但最多可以嵌套两级子报表,第一级子报表还可以包含任意数目的子报表。,1,用向导创建子报表,利用向导创建子报表的步骤如下。,(,1,)在设计视图中打开作为主报表的报表,例如“学生成绩表”报表。,(,2,)按下工具箱中的“控件向导”工具。,(,3,)单击工具箱中的“子窗体,/,子报表”按钮,如图,6-2-8,所示。,(,4,)在报表上单击需要放置子报表的插入点,同时打开“子报表向导”对话框之一,如图,6-2-9,所示,选择“使用现有的表和查询”单选钮。,6.2,编辑和打印报表,图,6-2-8,单击“子窗体,/,子报表”按钮 图,6-2-9,“子报表向导”对话框之一,6.2,编辑和打印报表,(,5,)单击“下一步”按钮,调出“子报表向导”对话框之二,如图,6-2-10,所示,在“表,/,查询”列表框中选择“学生成绩表”,并将所选字段添加到“选定字段”列表中。,(,6,)单击“下一步”按钮,调出“子报表向导”对话框之三,如图,6-2-11,所示,输入子报表的名称。,图,6-2-10 “,子报表向导”对话框之二 图,6-2-11 “,子报表向导”对话框之三,6.2,编辑和打印报表,(,7,)单击“完成”按钮,子报表添加完毕。,打印预览结果如图,6-2-12,所示。,如果不用向导创建子报表,而将一个已有的子报表直接添加到已有的主报表中,可以单击数据库窗口的“报表”选项卡,然后将要作为子报表的已有报表直接拖动到主报表的设计视图中,如图,6-2-13,所示。,图,6-2-12,打印预览结果 图,6-2-13,将已有报表直接拖曳到主报表,6.2,编辑和打印报表,2,链接主报表和子报表,将子报表插入到主报表时,如果两个报表基于相关的表将自动链接主报表和子报表。如果由于某些原因向导没有正确链接表,则用户可以进行如下操作进行链接。,(,1,)在设计视图中打开主报表,然后选定子报表的控件并打开“属性”对话框。,(,2,)把子报表中的链接字段名称输入到“链接子字段”文本框中。,6.2.4,页面设置,打印的页面设置会影响报表的形式,因此在打印之前要进行页面设置。,页面设置的操作步骤如下。,(,1,)单击“文件”“页面设置”菜单命令,弹出“页面设置”对话框,单击“边距”选项卡,如图,6-2-14,所示。,(,2,)在“边距”选项卡中进行页边距的设置。单击“页”选项卡,如图,6-2-15,所示,在“页”选项卡中进行打印方向、纸张和打印机的设置。,6.2,编辑和打印报表,图,6-2-14 “,页面设置”(边距)对话框 图,6-2-15 “,页面设置”(页)对话框,6.2,编辑和打印报表,(,3,)单击“列”选项卡,如图,6-2-16,所示,在这个对话框中可以设置列数、列尺寸和列布局。,图,6-2-16 “,页面设置”(列)对话框 图,6-2-17,报表的属性表,6.2,编辑和打印报表,6.2.5,设计布局,报表的总体外观是指从全局出发定义报表自身的显示特征和报表各组成部分的属性,包括设置报表背景图片和自动套用格式。,1,向报表中添加背景图片,向报表中添加背景图片的步骤如下。,(,1,)在设计视图中打开相应的报表。,(,2,)双击报表选定器,打开报表的属性表,如图,6-2-17,所示。,(,3,)将“图片”设置为,.bmp,等文件。,(,4,)在“图片类型”中指定图片的添加方式。,(,5,)设置“图片缩放模式”可以控制图片的比例。,(,6,)设置“图片对齐方式”可以指定图片在页面上的位置。图,6-2-18 “,自动套用格式”对话框,2,自动套用格式报表,设置自动套用格式报表的步骤如下。,(,1,)在设计视图中打开相应的报表。,(,2,)单击“格式”“自动套用格式”菜单命令,出现如图,6-2-18,所示的对话框,在其中可以选择自动套用的格式或单击“自定义”按钮,自定义自动套用格式。,6.2,编辑和打印报表,图,6-2-18 “,自动套用格式”对话框,6.2,编辑和打印报表,6.2.6,预览报表,预览报表有版面预览和打印预览两种方法,通过版面预览可以快速核对报表的页面布局。在报表设计视图中,打开报表,单击“视图”“自动预览”菜单命令,如图,6-2-19,所示,就可预览报表的版面布局。,报表的打印预览直接在报表的预览视图中完成。,6.2.7,打印报表,首次打印报表时,要对报表的页边距、页方向和其他内容进行页面设置然后进行打印。,打印报表的步骤如下。,(,1,)单击“文件”“打印”菜单命令,调出“打印”对话框,如图,6-2-20,所示。,(,2,)在“打印”对话框中进行设置。,(,3,)单击“确定”按钮,开始进行打印。,6.2,编辑和打印报表,图,6-2-19,单击“视图”“自动预览”菜单命令 图,6-2-20 “,打印”对话框,6.2,编辑和打印报表,
展开阅读全文

开通  VIP、SVIP  下载更划算
下载10份以上建议开通 VIP 会员
下载20份以上建议开通SVIP会员


开通VIP      成为共赢上传

当前位置:首页 > 包罗万象 > 搞笑趣谈

移动网页_全站_页脚广告1

关于我们      便捷服务       自信AI       AI导航        关注我们

©2010-2026 宁波自信网络信息技术有限公司  版权所有

客服电话:0574-28810668  投诉电话:18658249818

gongan.png浙公网安备33021202000488号   

icp.png浙ICP备2021020529号-1  |  浙B2-20240490  

关注我们 :微信公众号    抖音    微博    LOFTER 

客服